Author Topic: Does SPARX 12 support XML 6.0?  (Read 844 times)

abetroba

  • EA Novice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Does SPARX 12 support XML 6.0?
« on: September 15, 2015, 06:56:17 am »
We have discovered that Microsoft no longer supports XML 4,0 and their guidance is to upgrade to XML 6.0.  When looking at our SPARX package, we know that XML Parser 4.0 SP2 is a corequisite.  We are in the process of packaging SPARX 12 for deployment and wanted to get confirmation from you that SPARX 12 is compatible with XML 6.0.  

Simon M

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6197
  • Karma: +47/-5
    • View Profile
Re: Does SPARX 12 support XML 6.0?
« Reply #1 on: September 15, 2015, 08:27:11 am »
Most people can run Enterprise Architect without ever noticing that their windows install is missing MSXML4. Unfortunately, there are some additional libraries that didn't get checked for MSXML6 compatibility before version 12 was released.

PS. There's a big difference between Microsoft's XML library v6 and XML 6 (which doesn't exist)
« Last Edit: September 15, 2015, 08:28:25 am by simonm »
Simon

support@sparxsystems.com

abetroba

  • EA Novice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Does SPARX 12 support XML 6.0?
« Reply #2 on: September 15, 2015, 08:58:31 am »
So bottom line, your response is that SPARX 12 is not compatible with MSXML library version 6.

Simon M

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6197
  • Karma: +47/-5
    • View Profile
Re: Does SPARX 12 support XML 6.0?
« Reply #3 on: September 15, 2015, 12:33:54 pm »
It's not that black and white.

The standard EA installer doesn't install either version of MSXML for remotely recent versions of Windows. That means that the many of our users are running exclusively with MSXML 6 and have never seen a problem.

If you're asking these questions, you need to consider for yourself if you're more concerned with preventing usage of an "unsupported" Microsoft technology or functionality of things like an ArcGIS export. EA will work with just MSXML 6 available. That's enough for me to say it's supported.
Simon

support@sparxsystems.com