Author Topic: Default Color after installing EA 12.1  (Read 1727 times)

Kristofer

  • EA User
  • **
  • Posts: 40
  • Karma: +0/-0
    • View Profile
Default Color after installing EA 12.1
« on: February 04, 2016, 09:55:33 pm »
Hi!

I recently installed EA 12.1 (had previously 12.0). We have always used white color as default color for elements in diagrams, but after I've installed the new version, the elements changed to another color. I have tried to change the default color in Tools->Options, both for "Gradients and Background" (although we don't use gradients) and "Standard Colors", but nothing happens.

If I click on the element in the diagram and click on the Fill element tool, it says it has the default color, and I can also change it to white. I do not however want to change the color for all elements in all out diagrams. And besides, all new elements created has this other color we do not want to use, so that would require us to set the color for each new element.

Has anyone else noticed this, and how do I get the default color back?

/Kristofer

SilverSage

  • EA User
  • **
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: Default Color after installing EA 12.1
« Reply #1 on: February 05, 2016, 05:40:20 am »
Kristofer -

Welcome to my world. ;)  We had the same issue with color changes and there are several solutions. In my mind, none of them are elegant and the one I chose for my group works, but it has limitations.  I'll let you read for yourself; here's a link I think will help you:

http://sparxsystems.com/enterprise_architect_user_guide/12.1/building_models/using_element_templates.html

Enjoy!

Michael

Simon M

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6215
  • Karma: +49/-5
    • View Profile
Re: Default Color after installing EA 12.1
« Reply #2 on: February 05, 2016, 08:28:20 am »
Is your problem the 'Use Element Group Style' option on the appearance options page?

It overrides the global element color based on the object type.
Simon

support@sparxsystems.com

Geert Bellekens

  • EA Guru
  • *****
  • Posts: 7812
  • Karma: +171/-21
  • Make EA work for YOU!
    • View Profile
    • Enterprise Architect Consultant and Value Added Reseller
Re: Default Color after installing EA 12.1
« Reply #3 on: February 05, 2016, 06:01:16 pm »
Also don't forget the check the diagram theme in View|Visual Styles. If you have another theme the elements may look different for you then they are for someone with another active theme.

Geert

Kristofer

  • EA User
  • **
  • Posts: 40
  • Karma: +0/-0
    • View Profile
Re: Default Color after installing EA 12.1
« Reply #4 on: February 05, 2016, 07:22:12 pm »
Simon,

That was the solution! If I unchecked it, the white color got back.

But I am not sure I understand what it means. The documentation says "...with objects derived from a common element having the same color...". Where can I find this common element?

We will upgrade to 12.1 (from 12.0) in our company because of a bug fix we need, and I would prefer our users to not have to change any settings to get it to look as it used to be. So if I can change the "common element" it would be fine, right? Or can this have other effects I need to be aware of?

zyx

  • EA User
  • **
  • Posts: 74
  • Karma: +1/-1
    • View Profile
Re: Default Color after installing EA 12.1
« Reply #5 on: February 08, 2016, 04:49:41 am »
Where can I found this option? I didn't found it here... The color of my use cases is blue and I want to change it to white. I got to do it with my classes in the tools -> options, but it does not work with use cases...

skiwi

  • EA Practitioner
  • ***
  • Posts: 1727
  • Karma: +23/-49
    • View Profile
Re: Default Color after installing EA 12.1
« Reply #6 on: February 10, 2016, 12:18:11 pm »
Orthogonality rules
Using EA12.1 (1229) on Windows 10 Enterprise/64 bit. Repositories in SQLServer2014 R2 & Access2003/JET4.0

zyx

  • EA User
  • **
  • Posts: 74
  • Karma: +1/-1
    • View Profile
Re: Default Color after installing EA 12.1
« Reply #7 on: February 11, 2016, 03:53:54 am »
Thank you, it workek!