Author Topic: Behavior no longer showing on CallBehavior actions  (Read 490 times)

marke

  • EA User
  • **
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Behavior no longer showing on CallBehavior actions
« on: May 24, 2017, 09:41:48 pm »
Just opened a diagram that has not been opened for a while. It seems throughout the model that the behavior is no longer showing on CallBehavior actions (those with a pitchfork).

I can't find an option or setting to control this. Has anyone else seen this and know what is going on? I am using EA 13.0.01309.

E.g.

   ______________
 |   actionname       |
 |   : CBname          |
 |______________|

now looks like (can't show pitchforks in bottom-right corner)

  ______________
 |   actionname       |
 |                            |
 |______________|

KP

  • EA Administrator
  • EA Expert
  • *****
  • Posts: 2441
  • Karma: +29/-2
    • View Profile
Re: Behavior no longer showing on CallBehavior actions
« Reply #1 on: May 25, 2017, 08:53:45 am »
ISTR we changed it to match the UML spec better, but there's an option to revert to the old behaviour: ribbon | Start | Workspace | Preferences | Objects | Show invoked Activity name
The Sparx Team
support@sparxsystems.com

marke

  • EA User
  • **
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: Behavior no longer showing on CallBehavior actions
« Reply #2 on: May 25, 2017, 05:09:50 pm »
Thank you KP. I fell into the trap of thinking the Preferences would be under the Configure ribbon along with Model options.