Author Topic: Proxy Connectors Lost On XMI Import and Baseline Restore  (Read 578 times)

abaltins

  • EA Novice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Proxy Connectors Lost On XMI Import and Baseline Restore
« on: June 08, 2017, 01:32:33 am »
In our modeling efforts we are using the new "Proxy Connector" functionality to connect classes to connectors.  The functionality works well but when we are working offline (and want to reimport via XMI) or restore a package from a baseline, the connectors are lost from all diagrams that use them.

Looking at the backend database (both SQL Server and MS Access) the Proxy Connector objects are still in the t_object table but the connections are lost from the t_connector table.

EA 13.0.1310

Help!

Arnis
« Last Edit: June 08, 2017, 03:15:52 am by abaltins »

qwerty

  • EA Guru
  • *****
  • Posts: 8964
  • Karma: +136/-123
  • I'm no guru at all
    • View Profile
Re: Proxy Connectors Lost On XMI Import and Baseline Restore
« Reply #1 on: June 08, 2017, 04:16:07 am »
The word "new" above shouts "report a bug".

q.

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 5880
  • Karma: +71/-77
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
Re: Proxy Connectors Lost On XMI Import and Baseline Restore
« Reply #2 on: June 08, 2017, 10:06:05 am »
The word "new" above shouts "report a bug".

q.
@abaltins  - quickly report a formal bug using the links at the bottom of the page.

We are using ProxyConnectors a lot now and this is serious, if confirmed!

Paolo
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!

abaltins

  • EA Novice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Proxy Connectors Lost On XMI Import and Baseline Restore
« Reply #3 on: June 08, 2017, 10:58:00 pm »
I have a model where it occurring quite often along with EA crashes on opening of some diagrams.  I have run the integrity check/repair and it appears to have fixed the diagram crashes and will get back to you to confirm if my XMI import/Baseline restore issues have been resolved as well.