Author Topic: One user in the team not able to lock packages / elements  (Read 612 times)

heba

  • EA User
  • **
  • Posts: 27
  • Karma: +0/-0
    • View Profile
One user in the team not able to lock packages / elements
« on: December 14, 2017, 07:50:57 pm »
Hi all,

We work in a team with EA on a SQL server-based model.  Security is enabled, we use windows authentication and have a EA group with common permissions.  These permissions include the "Lock Elements" permission.

Now one user in the team cannot lock packages or elements while all other can. I checked the permissions, the group rights and did not find a difference to others.  I also created a local user for him but it still did not work.

Does anyone have ideas where I can look further into the problem?  I don't have any idea how to debug this .)  Maybe there are local settings which I'm not aware of?

Thanks in advance!
Heiko

Geert Bellekens

  • EA Guru
  • *****
  • Posts: 8027
  • Karma: +183/-22
  • Make EA work for YOU!
    • View Profile
    • Enterprise Architect Consultant and Value Added Reseller
Re: One user in the team not able to lock packages / elements
« Reply #1 on: December 14, 2017, 08:16:34 pm »
Heiko,

How do you know that he can't lock packages or elements?
Do you get an error?
Is the menu option not there?
Is the menu option grayed out?

Geert

heba

  • EA User
  • **
  • Posts: 27
  • Karma: +0/-0
    • View Profile
Re: One user in the team not able to lock packages / elements
« Reply #2 on: December 14, 2017, 10:19:49 pm »
Hello Geert,

The option does not show up in his EA.

My menu looks quite complete with some options greyed out:
 - Apply/release user lock...
 - Configure
 - Package Baselines
 - (greyed) Save package ...
 - (greyed) Load package ...
 - (greyed) View package ...
 - Compare package with XMI
 - Merge package with XMI
 - (greyed) Import a model branch
 - Version control settings

His menu:
 - Merge package with XMI
Nothing else.

Kind regards
Heiko

Geert Bellekens

  • EA Guru
  • *****
  • Posts: 8027
  • Karma: +183/-22
  • Make EA work for YOU!
    • View Profile
    • Enterprise Architect Consultant and Value Added Reseller
Re: One user in the team not able to lock packages / elements
« Reply #3 on: December 14, 2017, 10:45:03 pm »
I see, your collegue is a victim of "Workspaces and commands"

There are a number of predefined menu sets that limit the menu options.
In order to get them all back go to
(V13) Ribbon Start | Workspace | Perspectives | Menu Sets and choose the option Complete

In v12 this functionality is somewhere under the View menu IIRC.

Geert


heba

  • EA User
  • **
  • Posts: 27
  • Karma: +0/-0
    • View Profile
Re: One user in the team not able to lock packages / elements
« Reply #4 on: December 14, 2017, 10:59:57 pm »
Yes, this is the solution!  Thank you!

I never used this feature and I wonder how he switched it on.  Anyway, it works and now he can start working  ;)

Heiko

Geert Bellekens

  • EA Guru
  • *****
  • Posts: 8027
  • Karma: +183/-22
  • Make EA work for YOU!
    • View Profile
    • Enterprise Architect Consultant and Value Added Reseller
Re: One user in the team not able to lock packages / elements
« Reply #5 on: December 14, 2017, 11:38:06 pm »
Yes, this is the solution!  Thank you!

I never used this feature and I wonder how he switched it on.  Anyway, it works and now he can start working  ;)

Heiko
When first installing or upgrading to version 12 you get a popup asking to choose a perspective.
If you then choose for something like "Business analyst" (which is logical if that is your function) then you are stuck with that perspective as your default perspective.

Geert

qwerty

  • EA Guru
  • *****
  • Posts: 9203
  • Karma: +140/-132
  • I'm no guru at all
    • View Profile
Re: One user in the team not able to lock packages / elements
« Reply #6 on: December 14, 2017, 11:56:39 pm »
This must be a useful feature since it has been invented by skilled programmers. And therefore we will all see this question until doomsday, because it's out of question to remove it.

q.