Author Topic: Connector to Package leads to EA Crash  (Read 532 times)

A.K.

  • EA Novice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Connector to Package leads to EA Crash
« on: June 14, 2012, 05:45:15 pm »
Hello

I have to create some connectors from packages to elements and vice versa. However, when i do  so, the EA crashes with an SEHException.

None of the following approaches have worked so far:

1)
Create Element A
Create Package B
Create Connector C by ElementA.Connectors.Add
Link Connector to the Element of the Package (PackageB.Element)

2)
Create Element A
Create Package B
Create Connector C by PackageB.Connectors.Add
Link Connector to the Element A

3)
Create Element A
Create Package B
Create Connector C by PackageB.Element.Connectors.Add
Link Connector to the Element A


Different connector types such as "Package" (this type of connector is created when adding the connectors in EA manually) had no influence on the situation.


Any help is very appreciated!
Thanks!

Greetings,
Alex



Geert Bellekens

  • EA Guru
  • *****
  • Posts: 8204
  • Karma: +193/-23
  • Make EA work for YOU!
    • View Profile
    • Enterprise Architect Consultant and Value Added Reseller
Re: Connector to Package leads to EA Crash
« Reply #1 on: June 14, 2012, 07:36:14 pm »
Alex,

Have you tried connecting two existing packages/elements?
If that works it might be enough to reload the objects from the repository.

Geert

A.K.

  • EA Novice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Connector to Package leads to EA Crash
« Reply #2 on: June 14, 2012, 09:11:35 pm »
Thanks
As always I found it out just in the moment when I posted the question

the type must be "Dependency"