Author Topic: EA Addin Configuration Error  (Read 570 times)

Tehila1

  • EA User
  • **
  • Posts: 256
  • Karma: +0/-0
    • View Profile
EA Addin Configuration Error
« on: October 01, 2014, 09:12:15 pm »
I create an addin for EA v10.
When I launch it, I get the following error:  


Could not load file or assembly System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089\n  
Calling assembly : System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a.
LOG: This bind starts in default load context.

LOG: Using application configuration file: C:\PROGRA~1\SPARXS~1\EA\EA.exe.Config

LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v2.0.50727\config\machine.config.


LOG: Post-policy reference: System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089\r\nLOG: The same bind was seen before, and was failed with hr = 0x80070002.

I guess it is related to the config file in ProgramFiles\Sparx Systems folder. Its value is:  
  
Code: [Select]
<configuration>
  <startup useLegacyV2RuntimeActivationPolicy="true">
    <supportedRuntime version="v2.0.50727"/>
    <supportedRuntime version="v4.0"/>
  </startup>
</configuration>
 
  
Any ideas?

Ian Mitchell

  • EA User
  • **
  • Posts: 237
  • Karma: +2/-0
    • View Profile
Re:  EA Addin Configuration Error
« Reply #1 on: October 09, 2014, 09:05:06 pm »
Have you looked at Geert's excellent tutorial? http://bellekens.com/2011/01/29/tutorial-create-your-first-c-enterprise-architect-addin-in-10-minutes/
I think he talks about this.
Ian Mitchell, Designer, eaDocX

www.eaDocX.com
www.theartfulmodeller.com