Author Topic: BUG: Metatype attributes not respected  (Read 1011 times)

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
BUG: Metatype attributes not respected
« on: January 04, 2008, 09:22:52 am »
When creating a profile, you can set several metatype attributes to control settings in the Set Feature Visibility dialog. These include such attributes as _Tag, where a value of 1 should show the Tags compartment.

See Supported Attributes in EA help for more information.

When the profile is generated and imported, and an element with such a tag is added to a diagram, there is no visible difference. In the example, the Tags compartment is not visible.

If you open the Set Feature Visibility dialog, the appropriate boxes will be checked, reflecting the intended behavior, but not what is shown.

If you click OK to exit the Set Feature Visibility dialog is changed, the display is updated to reflect the settings from the profile. In the example the Tags compartment would now be visible (unless the change was to clear that setting, of course). The display update occurs even if there were no changes made in the Set Feature Visibility dialog.

Clicking Cancel to exit the Set Feature Visibility dialog does not update the display. In the example, the Tags compartment would not be visible, even though it continues to be set to display.
No, you can't have it!

Mr. Sanders

  • EA User
  • **
  • Posts: 186
  • Karma: +0/-0
  • Dilbert for president
    • View Profile
Re: BUG: Metatype attributes not respected
« Reply #1 on: January 07, 2008, 05:18:33 am »
Hello,

I had the same problem a couple of weeks ago and asked for a solution here, but haven't got an answer till now.

It seems that EA just ignores them.

Michael
« Last Edit: January 07, 2008, 05:19:00 am by mizd »

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re: BUG: Metatype attributes not respected
« Reply #2 on: January 07, 2008, 05:24:20 am »
Hi Michael,

I filed the bug report immediately after I started the thread. The workaround I mention above does cause the display to correct itself, but it is a strictly manual procedure.

We really need to get this resolved. It would be good to extend the "supported attribute" set, but first they need to be respected by the engine.

David
No, you can't have it!

Mr. Sanders

  • EA User
  • **
  • Posts: 186
  • Karma: +0/-0
  • Dilbert for president
    • View Profile
Re: BUG: Metatype attributes not respected
« Reply #3 on: January 07, 2008, 05:28:56 am »
Hi David,

have you got a response to your bug report?

I think it will be fixed with 7.1.

Additionally I think 7.1 is late, because we reported some
major bugs in december and they told us to fix them ASAP.

HM? Let's see what that means.

Michael

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re: BUG: Metatype attributes not respected
« Reply #4 on: January 07, 2008, 05:51:55 am »
Michael,

I too have hopes for some stuff in 7.1.

Let's hope our expectations aren't too great...

David
No, you can't have it!