Author Topic: (825) No Drag and Drop from project browser  (Read 3097 times)

Oliver F.

  • EA User
  • **
  • Posts: 573
  • Karma: +2/-1
  • Aren´t we all in the model business ?
    • View Profile
    • Karl Storz homepage
(825) No Drag and Drop from project browser
« on: February 20, 2008, 08:35:20 pm »
Suddenly drag and drop from to a diagram stopped working.
In fact I am unable to take elements, packages and other features and drag/drop  them onto a diagram, regardless the lock state.
I can see the cursor change when moving the element (with the + symbol), I can drop it but nothing happens afterwards. EA just simply returns without showing anything or giving any feedback.
On rather few occasions a dropped element is appearing but I would say this is one out of 20 attempts. From the toolbox I can drag and drop new elements without any problems.

Some days ago it used to work normally. I noticed this behavior with several different projects, be it database driven or from file system.

This is a serious issue, anybody noticed this or is it just me having overlooked something ?

[Update]: No issue with 818 so it is a bug related to 825. I will file this one.

Oliver
« Last Edit: February 20, 2008, 09:01:06 pm by ofels »

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re:  (825) No Drag and Drop from project browser
« Reply #1 on: February 20, 2008, 11:34:47 pm »
Sounds real to me Oliver,

Did you file one this via the beta bug report?

David
No, you can't have it!

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re:  (825) No Drag and Drop from project browser
« Reply #2 on: February 20, 2008, 11:37:09 pm »
And while I'm thinking about it, what about d&d from the Resource View? I can drag a pattern successfully, but this could be something triggered in your project configuration.
No, you can't have it!

Oliver F.

  • EA User
  • **
  • Posts: 573
  • Karma: +2/-1
  • Aren´t we all in the model business ?
    • View Profile
    • Karl Storz homepage
Re:  (825) No Drag and Drop from project browser
« Reply #3 on: February 21, 2008, 02:04:20 am »
Quote
And while I'm thinking about it, what about d&d from the Resource View? I can drag a pattern successfully, but this could be something triggered in your project configuration.

I don´t think it is project related as I tried it with several projects and even created a completely new one.

I filed a bug report for 818 as I did not find the beta bug page and marked it explicitely as being 825. I assume Sparx is smart enough to filter that appropriately (though I will do better next time *sigh*).

Oliver

thomaskilian

  • Guest
Re:  (825) No Drag and Drop from project browser
« Reply #4 on: February 21, 2008, 03:02:04 am »
As posted in the other thread I had it non-reproducible. With some clicks to other elements and changing the focus it worked again after a while. Also it seems that the behavior has stopped and it's working normally now. :-?

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re:  (825) No Drag and Drop from project browser
« Reply #5 on: February 21, 2008, 10:28:25 am »
Quote
...
I filed a bug report for 818 as I did not find the beta bug page and marked it explicitely as being 825. I assume Sparx is smart enough to filter that appropriately (though I will do better next time *sigh*)...
It's on the beta download page Oliver. It was not there for the first few days, so you would not have seen it if you downloaded early.

David
No, you can't have it!

mrf

  • EA User
  • **
  • Posts: 312
  • Karma: +0/-0
    • View Profile
Re:  (825) No Drag and Drop from project brow
« Reply #6 on: February 21, 2008, 10:36:31 am »
Hi Everyone,

I'm currently looking into this problem for Oliver but have not been able to reproduce it. If anyone can get it into a reproducable state, please feel free to send the EAP file through to  support@sparxsystems.com.au marked for my attention.

PS: Any details regarding what plugins/technologies you have installed would also be a great help.
« Last Edit: February 21, 2008, 10:39:29 am by mfraser »
Best Regards,

Michael

support@sparxsystems.com
"It is more complicated than you think." - RFC 1925, Section 2.8

thomaskilian

  • Guest
Re:  (825) No Drag and Drop from project browser
« Reply #7 on: February 21, 2008, 06:08:16 pm »
I'm using Parallels on my Mac. What happens regularly is a similar behavior: I drag something from the browser and when I drop it on the diagram, nothing happens. BUT: when I hover back over the browser the element is now hooked and with another click I can drop it on the diagram. That has been the case already with former releases. This new behavior has only started with the beta.

Oliver F.

  • EA User
  • **
  • Posts: 573
  • Karma: +2/-1
  • Aren´t we all in the model business ?
    • View Profile
    • Karl Storz homepage
Re:  (825) No Drag and Drop from project browser
« Reply #8 on: February 22, 2008, 12:10:40 am »
Quote
BUT: when I hover back over the browser the element is now hooked and with another click I can drop it on the diagram. That has been the case already with former releases. This new behavior has only started with the beta.

That one, unfortunately, is different.
Just reinstalled 825 over 818 and it is here again.

Oliver

thomaskilian

  • Guest
Re:  (825) No Drag and Drop from project browser
« Reply #9 on: February 22, 2008, 01:14:27 am »
Does that mean you are also using Parallels?

Oliver F.

  • EA User
  • **
  • Posts: 573
  • Karma: +2/-1
  • Aren´t we all in the model business ?
    • View Profile
    • Karl Storz homepage
Catched it...
« Reply #10 on: February 22, 2008, 03:00:18 am »
Quote
Suddenly drag and drop from to a diagram stopped working.

Folks, can you please do me a favor and verify the following in 825: Drop an element in the left 3rd/half of a diagram. It seems that everything dropped to the left is just omitted. I did not notice this because people having the project window at the left side tend to drop more in the left part, a browser to the right leads to not noticing this if the problem is on the left side of the diagram panel only.

This does not affect patterns dropped from the resource view, only project browser (thanks for the hint, David).

So if someone can verify this, I´d be glad.

Oliver

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re:  (825) No Drag and Drop from project browser
« Reply #11 on: February 22, 2008, 03:15:21 am »
Well, I've tried it. No problem no matter where I drop things.

David
No, you can't have it!

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re:  (825) No Drag and Drop from project browser
« Reply #12 on: February 22, 2008, 03:23:10 am »
Oliver,

OK - I got one to fail!

I created a new project in 825 - just in case; I don't think this is structural. Note that my EABase has been edited, so there are no views by default.

I added a view, package, and class diagram (each nested). I use the New Element (control-M) dialog to add several new classes to the package (but not the diagram.

Then I randomly dragged several of the classes onto the diagram surface. The problem occurred once.

What seems to happen is that the mouse click to select the element in the browser fails somehow. You'll notice this before the drop failure. In the browser tree the 'selected' element is not highlighted, but appears dimmed out. As mentioned in an earlier post this can be corrected by a keystroke (escape seems to work), leaving the element selected normally, after which it can be dropped.

David
No, you can't have it!

«Midnight»

  • EA Guru
  • *****
  • Posts: 5651
  • Karma: +0/-0
  • That nice Mister Grey
    • View Profile
Re:  (825) No Drag and Drop from project browser
« Reply #13 on: February 22, 2008, 03:30:06 am »
Better yet, I've been able to reproduce the problem.

I've sent an email with the project to Michael.

David
No, you can't have it!

Oliver F.

  • EA User
  • **
  • Posts: 573
  • Karma: +2/-1
  • Aren´t we all in the model business ?
    • View Profile
    • Karl Storz homepage
Re:  (825) No Drag and Drop from project browser
« Reply #14 on: February 22, 2008, 03:32:46 am »
Quote
What seems to happen is that the mouse click to select the element in the browser fails somehow. You'll notice this before the drop failure. In the browser tree the 'selected' element is not highlighted, but appears dimmed out. As mentioned in an earlier post this can be corrected by a keystroke (escape seems to work), leaving the element selected normally, after which it can be dropped.

Nope, sorry. Mine is different, as I get the selection and the cursor changes to the dragging icon.

Interesting: The coordinates on which it refuses to drop things are absolute. I just enlarged the project browser to 2/3 of the screen and I can drop items on the left side of the diagrams (because the left edge is now starting beyond the half of the display, note my project browser is left).

Oliver