Author Topic: eclipse not integrating with EA  (Read 675 times)

Xavi

  • EA Novice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
eclipse not integrating with EA
« on: November 30, 2011, 02:45:24 am »
I have tried to integrate eclipse with eclipse Galileo and Indigo and I've had no luck so far, when I use Indigo i get this error:
Code: [Select]
Could not create the view: Plug-in org.sparx.eaintegration.eclipse was unable to load class org.sparx.eaintegration.ui.internal.modelview.ModelExplorerPart.and when I use Galileo I don't get the error but nothing works, I click on the open UML model button and nothing happens,

I' ve already check on the plugins for the installation details and I have the following plug-ins installed:
Code: [Select]
SparksSystems     MGDIntegrationforEclipse Core Plugin      4.0.0
SparksSystems     MGDIntegrationforEclipse JDT Plugin       4.0.0
SparksSystems     MGD Link for Eclipse Core Plugin          4.0.0
SparksSystems     MGD Link for Eclipse JDT Plugin           4.0.0

from the error in Indigo I'm assuming my problem is plugin related but I'm not sure where to go from there, I would really appreciate If anyone could shed some light on this.

Thank you

*btw I Initially posted this on Automation Interface forum by mistake It should have been on this one in my opinion, I don't mean to cause any inconvenience so I would appreciate it if a moderator could delete my old post.

Aaron B

  • EA Administrator
  • EA User
  • *****
  • Posts: 868
  • Karma: +11/-0
    • View Profile
Re:  eclipse not integrating with EA
« Reply #1 on: November 30, 2011, 09:23:16 am »
What Operating System are you running?  Is your O/S 32-bit or 64-bit?  If 64-bit, is your Eclipse installation 32-bit or 64-bit?

Have you tried running Eclipse as administrator on your computer?  Does this make any difference?

P.S. Your post on the Automation Interface message board has now been deleted.  Thank you for indicating your accidental cross-post.

Xavi

  • EA Novice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re:  eclipse not integrating with EA
« Reply #2 on: November 30, 2011, 11:21:07 am »
I'm running it on windows 7 ultimate 64 bits, Indigo is x86_64 and the galileo version is x86 win 32

is from the Indigo version that I get the error described on my first post and from the galileo version I get nothing, it just does not work.

also when I clicked on the details for the error on Indigo the first line says:
Code: [Select]
org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle org.sparx.eaintegration.eclipse (937).

and when I run enterprise eclipse I'm able to see the active eclipse packages on the Eclipse Connections window but nothing shows for Selected

I also tried running eclipse as an administrator as you suggested and I get the same results, It does not make any difference.

Thank you

Aaron B

  • EA Administrator
  • EA User
  • *****
  • Posts: 868
  • Karma: +11/-0
    • View Profile
Re:  eclipse not integrating with EA
« Reply #3 on: November 30, 2011, 11:38:53 am »
MDG Integration is not compatible with the 64-bit version of Eclipse and is known to result in various error messages.

Please download and install the 32-bit version of Eclipse, then re-install MDG Integration.  Does this resolve the problem?

Please note that when installing MDG Integration it will only install the plugins into the Eclipse directory specified during the installation.  If you have multiple versions of Eclipse installed, only the one in the directory you specified will be properly configured.


Xavi

  • EA Novice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re:  eclipse not integrating with EA
« Reply #4 on: December 07, 2011, 03:49:40 am »
Thank you very much Aaron, It finally worked!
Did what you suggested, reinstalled galileo and mgd integration and I was able to connect to my projects.

Now my problem is, Is there a way to extend the trail period of the mgd eclipse integration and EA? because I now only have one day left in the trial and would like to really try the software.


RoyC

  • EA Administrator
  • EA Practitioner
  • *****
  • Posts: 1157
  • Karma: +8/-3
  • Read The Help!
    • View Profile
Re:  eclipse not integrating with EA
« Reply #5 on: December 07, 2011, 09:14:21 am »
Send an email to Sparx Sales and request an extension key. This is generally for another 30 days but if you need a longer period that can be arranged too.

sales@sparxsystems.com
Best Regards, Roy