Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - rvi1cob

Pages: [1]
Uml Process / MDG Technology - Stereotype - Linked Document
« on: March 06, 2017, 05:06:32 am »
Hello Everyone,

I am looking for a possible option for the below scenario.

I have a set of stereotypes defined in my MDG technology. Each of it has to be associated with its own "Linked document" template. I created as set of linked documents along with the MDG Technology.

After the technology is imported:
Is there any way when I create an element of the defined stereotype, the linked document is associated by default to a linked document template?

The reason is I have multiple stereotypes and each should use its own linked template. It would be weary to go through a list of document template otherwise.


Thanks Geert :)

Dear All,

I am trying to create UML profiles with custom icon/images.
I understood that in order to show custom icon for my stereotype, I must use shapescript and accordingly this is done.

Now the problem is with the transparency. When I use png file with transparency it shows good in "image manager", but when I use in shape editor, I get black background, and accordingly after importing MDG Technology, the stereotype renders black background.  :(
I am using png format.

Is there any workaround?


found the problem. It works only when the metaclass is of type "Class". I was using metaclass "Table".
Thanks for your hints.


Yes. already included  :(

Hi Geert,

Thanks for the hint.
I tried in the shape editor and in the preview, it showed the desired icon.

But it is still not working, after generating new MDG and importing it.

Note: The default appearance setting is reflecting correctly when I drag and drop for creating new elements.

Any other settings that I should check.


Hi Everyone,

I am new for developing MDG Technology, wondering to get some help.

I have to create custom elements for my project and below is the requirement. While creating new elements in the diagram, the element should pick-up a default icon for appearance.

This is what I tried, (as guideline)

1. Created a Stereotype for my metaclass
2. In the Option : Edit with profile helper -- Assigned - icon (16 x 16) and _metatype: block

After generating MDG file and importing my MDG Technology, I tried to create a new element in my MDG diagram, but found that

1. In the toolbox - icon is assigned
2. When I drag and drop the element to create one, it has the default box. But here the expectation is the custom icon.

Any guidance, what exactly should I do to acheive this?


Pages: [1]