Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - shirleyj

Pages: [1]
Suggestions and Requests / Import doc/pdf to a document in EA
« on: September 19, 2011, 10:30:40 pm »
When importing outside documents to an EA document, i can't import Pdf/Doc files.
A lot of documents are from that type and i think its neccassary that it should be possible to import this types as well.
i'd love to hear if someone has other ideas about how to import this kind of documents (beside saving them as RTF files).
Tanks in Advance,

Suggestions and Requests / EA in cloud environment?!
« on: June 23, 2011, 06:35:50 pm »
this question is refered mainly to the sparx team..
Is there any future planning to turn EA to  a cloud environment inerface

General Board / Filter speciffic tagged value in generated rtf doc
« on: December 29, 2011, 07:32:55 pm »
I want to generate a rtf doc that will show me only specific tagged value from a list of many tags that are included in elements.
i tried using the filters in the doc. generator but failed to filter the tags.
i also tried building sql search to do the same but the same result..
any ideas?
tnx in advance,

General Board / importing document to ea and creating requirements
« on: October 31, 2011, 07:30:15 pm »
I was wondering about an issue regarding the subject above.
I'm importing a document(pdf/rtf) to EA, in order to create requirements from it, i use this way in order to do kind of integrity check between the info in the document to the req. in the model.
The question is, what happens if i recieve an updated document?!
in one hand  want to keep track of the already existing req. in the model, and in the other hand i want to see the updates and complete them in my model req.
How can i do both in the same document artifact?!
Tnx in advanced,

General Board / What is the use of the Redefinition connector?
« on: August 25, 2011, 08:05:40 pm »
Hi All,
Im creating a profile, and usually i connect the sterotype to the metaclass with the 'extends' connector.
today i noticed the 'Redfinition' connector.
can someone explain in what cases should i use this connection?
I didnt find much info. in the EA Help function.
Please Advise,

Thanks In Advance,


General Board / Encrypt data on connection to DB
« on: July 12, 2011, 05:34:48 pm »
I'm implementing EA for one of our clients, and I'm trying to set a connection to a model whose located on SQL server.
Because the info On the model is of top importance and confidential, I was ordered to encrypt the connection to the db.
When setting the new connection to SQL db on the 'Data Link Properties' window, I go to the 'All' tab and there , appears a property named  'Use Encryption for data'. I set it to 'TRUE'.
After clicking OK, the station tries to connect to the DB, and then pops out a window, the requires a password.
This window appears only when setting the encryption property on.
I have no idea what pass I'm supposed to enter, I tried entering all the pass. I know, but no success setting the connection this way.
Please someone advise,  I need to find a way to encrypt the data so it would be safe.

General Board / audit log records
« on: July 11, 2011, 06:23:34 pm »
Does anyone know, in what table are the audit records stored?
Thanks in advance,

General Board / Preventing the option to write sql query
« on: April 27, 2011, 11:57:49 pm »
Hi to all,
Is there any way i can prevent the option, to search info in a model using sql queries?
i want to prevent this option for some of my EA users.
Thanks in advance,

Bugs and Issues / Different views on project Task Allocation
« on: January 26, 2012, 09:07:12 pm »
Does anyone know's  if there's a possibility to change the gant view to different time units like weeks, months ,etc..??


Bugs and Issues / repository connection error
« on: September 25, 2011, 11:51:38 pm »
we have are own addin that loads info. from the repository.
i have no problem loading info. from a local EAP,
but when connecting to the repository, i recieve an error that says:
"Microsofe OLE DB Provider for SQL Server [-2147467259] Connection failure"
did someone encountered this as well.
Im sure its not an EA issue but still maybe someone can advise a solution?
Tnx in advance,

I have a custom made profile.
I made some changes on an element's tagged value and reloaded it to my model.
i tried synchronizing the element types that have been changed, but it doesn't work.
The 'Synch profiled elements' window doesn't show any elements on the  'Acttion' list.
I also checked the elments and didn't saw any changes.
Please advise,

Bugs and Issues / doubled tagged values
« on: April 06, 2011, 01:32:55 am »
I have created a model with customized elements, by creating my own profile with the elements that i need, including predefined tagged values.
Our developer used my model to create customized add in's. one of them takes the info from the tagged values and displays it.
The problem is, that it shows every tagged value twice!
I talked to the dev. about the problem, he claims that somewhere in the DB, the tagged values are stored twice.
I must note, that during time i change the structure of my elements on the profile and synchronize the model's elements in accordance. Maybe that is the reason for the doubled values??
Anyway,i didnt find any doubled info in the DB.
Can someone please target me to where can i might find the doubled values?
Thanks in advance,

Bugs and Issues / changing stereotypes issues
« on: March 14, 2011, 02:20:42 am »
we tried to automaticlly change stereotypes in a model, with the help of a generated source code we wrote.
the stereotypes in the objects were successfully changed but in the links manager we can see an object's, old and new stereotypes.
Inside the DB, we went to the t_objects table and the t_stereotypes table, and only the new stereotypes exist.
Maybe there is a 3rd table with a stereotype's information exists, but we don't know where to look for it (and if it really exists).
I will be happy if someone can assist me solve the problem of double stereotypes, or how to fix this issue.
Thanks in advance,

Uml Process / connection between a service to a button
« on: June 14, 2011, 07:31:43 pm »
I have 2 elements:
1. a button on a screen (in an interface diagram)
2. a use case whose a buissness service.
Pressing the button,activates the service.
what kind of a connector do i use to describe the connection between them?
thanks in advance,

Pages: [1]