Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - eric.meredith

Pages: [1]
1
General Board / Controlling Access to objects, packages, features
« on: December 07, 2017, 07:15:25 am »
How do I control who can access, edit, manage, etc various packages, objects, or features of SPARX?
Eric

2
General Board / Non-visual associations
« on: October 12, 2017, 06:29:36 am »
Self-identified newbie here.

I can draw a dependency between two objects and see their relationship in the Relationships window.

Is there a way to establish a relationship, without "drawing the lines", i.e. can I connect an Application to the Server it runs on, without placing either on a diagram and connecting them?

Thx,
Eric

3
General Board / Setting defaults for Attribute Visibility
« on: October 12, 2017, 02:30:50 am »
I am finding myself right-clicking on each and every server node and manually setting the visible attributes to a specific one (IP Address) clikcing on "Custom" checkbox, then "Custom" button, and then deselecting the ones I don't want. After that I click the checkbox to display Notes.

Is there a way to make these choices the default? Or is there a way to do this en masse?

Eric

4
I am a newbie to EA, but a "classic" in app dev.

This snippet should work, me thinks:
See this code snippet below:
Dim currentAttribute As EA.Attribute
Set currentAttribute = eaConn.addOrUpdateAttribute(currentClass, “IP_ADDRESS”, stereotype, description, attrType)
currentAttribute.Default = "1.2.3.4"

Now – I’ve obviously left a lot out here, but MOST of this works exactly as you would expect, enabling me to import server definitions into our SPARX repo quite nicely. The last line, however, does not work – and yet it appears to be correct.

It “IS” correct syntactically. It is supposed to set the Initial Value of an Attribute, in this case an attribute called IP_ADDRESS. In fact, If I use this code to create a Node (a server) and to create the IP ADDRESS attribute, it does everything EXCEPT insert the IP number. If I manually insert the IP number in EA, and then use the code to retrieve the attribute, why shock of wonder the IP_ADDRESS is there and is correct.

Thought? Help!!

Pages: [1]