Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - enteleform

Pages: [1]
1
Bugs and Issues / Diagram View Crashes App
« on: November 22, 2017, 06:28:32 am »
My project was working fine until today. Now, upon opening a diagram view, the view is loaded but doesn't show any actual data - just empty widgets. At this point, the app becomes unresponsive and crashes shortly after.

I tried exporting the root project to XML, and then importing it in a new EA document, but the problem persisted. I then tried deleting the diagram, creating a new one, and dragging the package elements onto it; but that also caused the app to crash.

Just now, I tried creating a new document to verify that the app is working properly; but I found that the diagram view will crash even on brand new, empty documents.

I also fully uninstalled EA, deleted "AppData\Roaming\Sparx Systems", and then reinstalled EA with the latest installer. The issue still persists.

2
I'm trying to use the conditional parameter of the list macro to organize the attributes in "Class Body" by stereotype.

For example:
Code: [Select]
...

public class MyClass{

  //###  Stereotype_A  ###
  public int myVar_1;
  public int myVar_2;

  //###  Stereotype_B  ###
  public int myVar_3;
  public int myVar_4;
...
}

I've tried various permutations of
Code: [Select]
%list="Attribute" @separator="\n" @indent="\t" (%stereotype == "Stereotype_A")%but haven't gotten anything to work yet.

(tried stereotype/classStereotype, various arrangements of the % symbol, with/without %if...% & %endIf%, with/without parenthesis, etc.)

Pages: [1]