Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Adrian Cook

Pages: [1] 2
1
General Board / Re: Requirements Tagged Values
« on: October 27, 2011, 04:29:38 am »
The last time I checked (I have v8.0) you cannot export tagged values using the Export to CSV functionality. You need to do it as an RTF report. I needed the tagged values in a spreadsheet so I wrote an RTF report template that generated a doc that I could convert to a CSV file by jumping through a couple of hoops.

Adrian

2
General Board / Re: Question re transformation templates
« on: October 27, 2011, 05:24:30 am »
Ok, I found an answer, though it's not the one I wanted. See http://www.sparxsystems.com/cgi-bin/yabb/YaBB.cgi?num=1296826206/5#5

3
General Board / Re: Question re transformation templates
« on: October 27, 2011, 05:10:32 am »
Sorry, I referenced the wrong macro in my post. I meant to say the CONVERT_TYPE macro, it's the one that maps the datatype from the source to the destination domain. The TRANSFORM_CURRENT macro does something different.

4
General Board / Question re transformation templates
« on: October 27, 2011, 04:58:01 am »
Hello,

I want to use the built-in DDL transformation template to transform our conceptual data model into an initial physical data model (for Oracle). I have a question about this functionality:

We have defined a number of enumerations that we are using as data types for certain attributes in our entities. The TRANSFORM_CURRENT macro doesn't know what to do with these when transforming an attribute into a table column so it leaves the data type unchanged in the column definition, even though these types are not supported by Oracle. Is there a way to add new data type mappings so that the macro will know how to map these custom types to Oracle types?

I've looked at the Database Datatypes dialog but it doesn't allow me to add a mapping to an Oracle type that already has one of the built-in generic types (e.g. char, float) mapped to it. Why can't I map multiple types from the source domain to the same destination domain (e.g. Oracle) type? This seems like a design flaw. For the same reason, the built-in boolean and int types don't have mappings to Oracle types and it won't let me add them either.

Any help would be appreciated.

Thanks
Adrian

5
General Board / Re: Re-sync status w/ VC provider for *ALL* pckgs
« on: June 29, 2011, 08:38:46 am »
This command used to run on all packages at once in EA 7.5. Now that we've upgraded to EA 8.0, I notice that the behaviour of this command has been changed so that it only runs on the currently-selected package. I don't know why this behaviour was changed in EA 8.0.

Is there a way to run this command on all packages at once in EA 8.0? It was very handy for the reason mentioned by the original poster.

Thanks
Adrian

6
General Board / Re: Using Login as Another User with AD-based acco
« on: June 29, 2011, 02:56:11 am »
One thing I forgot to mention: I have tried changing my password in the Change Password dialog when logged in as myself, but it won't accept my domain password in the old password box (nor a blank password) so I'm not able to specify a new password. Any ideas?

Thanks
Adrian

7
General Board / Using Login as Another User with AD-based accounts
« on: June 29, 2011, 02:47:11 am »
I have security enabled in my project and I'm trying out the feature to import user IDs from Active Directory because I don't want to maintain a set of EA accounts if I don't have to. Seems to work ok, however I can't figure out how to use the Login as Another User feature to login as a different user under this setup (specifically, to move from the default admin account back to my own account created from our Active Directory domain). That login dialog will not accept my domain username and password, nor my username without a password, even though EA will log me in with that account just fine when I open the project.

Does Login as Another User work under this setup? Do I need to re-open the project to log back in as myself? We're using EA 8.0.864.

Thanks,
Adrian

8
General Board / Re: Can EA do package or element-level access cont
« on: June 24, 2011, 04:22:57 am »
Thanks for the replies. So it sounds like implementing access control via our version control system seems to be the way to go. Any hints on how we'd go about this using Subversion? I haven't explored the Subversion documentation on this issue yet though it sounds like I (as the administrator) would need to ability to revoke checkout permissions on specific packages for specific users, without them being able to overide that.

BTW, since this is done via the version control system, I assume that only package-level access control is possible (as opposed to element-level control), since it is the packages that are version-controlled.

Thanks,
Adrian

9
General Board / Can EA do package or element-level access control?
« on: June 23, 2011, 08:04:36 am »
Is EA capable of enforcing access control at the individual package level or even the element level? I.e. Stopping a specific user or group from modifying any elements in package X, or specifially element Y? EA's security model seems to take an all or nothing approach, i.e. a particular user or group can modify everything or nothing, depending on whether or not they have been granted the Update Elements permission.

The description of workflow scripting in EA online help suggests that it is capable of implementing this, though the information about workflow scripting in online help is very limited.

We're using EA 8.0 with a shared DBMS-based project. Our packages are under version control in Subversion. Any tips would be appreciated.

THanks
Adrian

10
General Board / Re: Can I import values of custom attributes from
« on: December 17, 2009, 05:10:04 am »
Hi,

Thanks for the link to your Excel macro - it shows me how to do what I need to do. Now I just need to write a little VBA code!

Adrian

11
General Board / Can I import values of custom attributes from CSV?
« on: December 16, 2009, 07:24:15 am »
Hi folks,

We're planning to use EA on our project and we need to load some requirements and other external data currently in spreadsheets into the tool so that we can trace model elements to them. I've played with the import from CSV functionality but the problem is that it doesn't seem to allow the import of any attributes that are not already attributes of the EA Element type.

I know that I can define custom attributes on an element as tagged values, but that's little good to us if I can't load values for these attributes from an external source (there are too many values to manually input via the GUI). Does anyone have any ideas?

Also, is there a way to export the tagged values on an element to a spreadsheet?

Thanks,
Adrian

12
Bugs and Issues / Re: Help Needed: Disappearing data in EA 7.5 and S
« on: July 01, 2011, 07:55:14 am »
The problem of the disappearing operation definitions on our Interface elements is still happening to us, despite the fact that we recently upgraded as a team to EA 8.0 from EA 7.5. (For reasons I won't go into we can't move to EA 9 yet.) This is a really serious issue for us. Of the 52 Interface elements we have defined, the operations have disappeared from all but two of them. Not sure why those two were spared, though they are located in the same package.

I'm not convinced that this problem is related to the issues with inter-package dependencies and version control, since some of the operations that have disappeared did not have any obvious dependencies on data in other packages. (Some of the missing operations have parameters whose types are defined in other packages, while others do not.) Any ideas? THis is really frustrating.

Thanks,
Adrian

13
Bugs and Issues / Help Needed: Disappearing data in EA 7.5 and SVN
« on: May 04, 2011, 03:11:01 am »
Hi folks,

We're encountering a serious issue with disappearing data using EA 7.5 and Subversion for package version control. Here is the setup:

- Package A, under SVN version control, contains two Component elements, X and Y.

- Package B1, which is a sub-package of A but is under seperate SVN version control, contains a Component diagram showing components X and Y and the interfaces that they implement (see below). There are similar packages B2, B3, etc that are also sub-packages of A and are structured the same way.

- Package C1, which is a sub-package of B1 but is under seperate SVN version control, contains Interface elements C1x and C1y, each of which defines a set of operations. Component X implements interface C1x and component Y implements interface C1y via Realization relationships. There is a also a Sequence diagram in the pkg that shows message passing between components X and Y with respect to these particular operations. There are similar packages C2, C3, etc that are also sub-packages of B1 and are structured the same way.

This may seem like an awfully complex package structure but there's a reason for it.

Okay, here's the issue we're having: every now and then, most (but not all) of the operations shown in the Sequence diagrams in the C-level packages will simply disappear from the diagrams, even in packages that remain checked in. This seems to happen after the top-level (A) package has been checked out by someone on the team, even if they have made no changes directly in that package. (EA forces us to check out this package in order to update the Sequence diagrams in the C-level packages, presumably because we are adding operation invocations between the two components defined in that package.) We have also observed the Interface elements disappearing from the Component diagrams in the B-level packages. We're not sure why any of this is happening.

The new issue we ran into today is that the actual operation definitions have disappeared from ALL of the Interface elements in ALL of the C-level packages, despite the fact that those pkgs remain checked in to SVN. (At least it looks like the operations are gone - none are shown in the Project Explorer.) Again this happened after someone checked out the top-level package but did not change anything directly within it.

Anyone have any ideas as to what's going on here? We're totally stumped. This is a very serious issue that we need to resolve asap. We're working in a shared SQL Server-based EA project with a shared SVN repository for the packages under version control (everyone also has their own local copy of the XMI files for the packages under SVN control, as that is the way version control in EA with SVN works).

Any help would be appreciated.

THanks,
Adrian

14
Bugs and Issues / Locking of connectors does not work in EA 8.0
« on: June 28, 2011, 05:13:13 am »
Here's the background of my issue: Security is turned on in my project. There is a use case that is locked by a certain group. That use case has connectors (Realization relationships) pointing to multiple requirements in a different package. Those requirements are also locked, by a particular user.

Here's the issue: I can delete those connectors from the Relationships window, even though I am logged in neither as the user that has locked the requirements nor as a member of the group that has locked the use case. This appears to be a bug, especially since online help states: "If an element is locked, connectors attached to it are also locked. To unlock the connector, you must unlock the element." Well, they sure don't seem locked to me.

Has anyone else ran into this? Has it been reported as a bug? We're running EA 8.0.864. I've scanned the list of changes in versions since then and I don't see anything to suggest that this problem has been fixed.

Thanks,
Adrian

15
Uml Process / Re: Business entity not a stereotyped class?
« on: April 07, 2010, 09:51:31 am »
Is there anyone from Sparx monitoring this list who can answer my question? Is there anyone out there at all who's using this Business Modeling notation? (And I'm NOT referring to BPMN.) I'm getting the impression that no one is using this notation.

Adrian

Pages: [1] 2