Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - peterc

Pages: [1] 2
1
General Board / Re: Export elements from several subpackages to CSV
« on: February 19, 2018, 07:04:23 pm »
If you right-click on the parent package and select Import/Export - CSV Import/Export, then there is a tick-box for "Include Subfolders", which is ticked by default (at least on mine). If you build a specification with the appropriate items then it will export sub-packages as well.

2
General Board / Re: Diagram Title / Details Block
« on: February 09, 2018, 01:42:52 am »
Right click on the diagram background, Select Diagram and Show Diagram Details shows some basic information about the diagram. I presume the information is fixed which would not cover all of the items in your list.

How about using an element and tagged values? I'm not sure which element would be best, but a Requirement might work - you could use the Name for the drawing title and then define tagged values for each of your other fields. You could probably even create a custom shape pre-loaded with all your desired tags and create an MDG Technology so that it appears in your own custom toolbox.

3
General Board / Re: Creating a Navigation Cell from a Matrix Profile
« on: January 11, 2018, 10:46:40 pm »
They have probably been designed for diagrams but do work for a matrix.

I've just found a quicker way of generating them:
  • Drop a hyperlink onto the diagram, selecting the desired matrix
  • Change the Stereotype to NavigationCell

The only disadvantage is that it is not possible to select the images that diagram navigation cells have.

4
Not sure about action pins specifically, but on some elements the source of an element is hidden by unchecking "Show Namespace" found by right clicking on the diagram, select properties and then the Diagram selection and then within Appearance.

5
I was dropping ValueType elements, so I have changed and dropped a Property on - all works now.

If anyone else comes across this in the future, it is necessary to change the Type by opening the Property element and in the dialog under Properties - Property selecting a Value Type. Confusingly, the Type in the Properties window (not the dialog that is visible when opened from the element in the Project Browser) is not editable. That's too many uses of the word Type in windows/dialogs labelled Property but doing different things for my mind to cope with!

6
General Board / Creating a Navigation Cell from a Matrix Profile
« on: January 05, 2018, 02:03:12 am »
What is the correct way to generate a Navigation Cell for a matrix?

If I create a Navigation Cell from a diagram and and a Matrix hyperlink, I can then copy the link in the hyperlink onto the Navigation Cell so that the Navigation Cell opens the Matrix rather than the diagram. But... in doing so the nice image of the Navigation Cell disappears (and I shouldn't really have to copy the hyperlink!). There is a nice matrix image available in the Navigation Cell image library so hopefully there is a better way.

7
So, I have added Value Type elements to the diagram and they are in the Project Browser, but when I delete them off the diagram they do not appear in a "values" compartment. I do have "ports" and "parts" compartments (and they correctly follow the behaviour that if the element is on the diagram then it is not listed in the compartment; as soon as I delete them from the diagram then they appear in the compartment).

I think I am doing something wrong in dropping the ValueType element onto the Block - the parts and ports are constrained in the diagram to be within the boundary of the Block. The ValueType elements can be dragged anywhere on the diagram. Where they are on the diagram determines where they are in the Project Browser (they become a sub-element of the Block when dropped on top of it).

8
According to http://www.sparxsystems.com/resources/user-guides/model-domains/sysml-models.pdf page 21, Block elements can display any number of compartments. A ValueType element should appear in a "values" compartment.

I have turned on everything I can find under the Diagram Properties and the element's Features & Properties dialogues but cannot get ValueTypes to appear in a "values" compartment. I can get the ports compartment to display (if I delete the port from the diagram after creation). I can create a new Port by right-clicking on the element and selecting New Child Element. Similarly flow properties that are created as a child and deleted from the diagram show in a "flow properties" compartment.

I can't create a ValueType as a child element from that menu, but having created a Value Type I have moved it manually to make it a child of my Block element, but even then it doesn't appear in a compartment. There might be a clue in not being able to create a ValueType from the right-click menu, but that then also contradicts the SysML Models Guide.

I am using SysML 1.4, but have tried 1.3 as well and that is no different.

9
General Board / Re: Exclude connector type has no effect
« on: December 15, 2017, 12:22:30 am »
Are you using a "Defined Document" that you have created and "Auto Generate"? I have raised a bug report with Sparx that doing that the filters are not obeyed, with an acknowledgement that it will be fixed in a future release. They work fine if you first select from the Defined Document "Generate Document" and then "Generate".
If you have excluded all connectors then anything that you are reporting on in relation to connectors ought to have been filtered out.
I also seem to recall seeing some incorrect effects introduced on some of the version 13 beta releases in relation to document generation, but subsequently fixed after I reported them. So it might be worth trying a different version (either the latest or an older one depending on your current version) to see whether it behaves differently - it may be that you are correctly specifying the filter but it is not being obeyed in whichever version of EA you have installed.

10
General Board / Re: Adding Borders
« on: December 12, 2017, 11:59:54 pm »
That's ok - it's what the forum is for (and I've had my share of answers before).

11
General Board / Re: Adding Borders
« on: December 12, 2017, 02:16:43 am »
Did you want the border on the diagram in the model, or when it is exported? There is an option to add the border and diagram name to exported images? I think the name is on the top left (but stand to be corrected) - the option is in the Preferences under Diagram - Diagram Frames.
Just wondering as you mention fragments so you might be referring to saving the model as images.

12
I may have got the wrong end of the stick...

I presume that you have some parameter (e.g. Element Name) with a Paragraph Style of Heading 1 or Heading 2 etc.

If you have two templates then you can start from a different Paragraph Style in each.

For example, if you have a package called Requirements and in one template set the Paragraph Style to be Heading 2 and include Element Name in the heading then (assuming you use numbered headings) you will have something like "1.1 Requirements".

If you then choose in your other template Heading 3 as the Paragraph Style then the package name would be "1.1.1 Requirements".

As I said, I may have misunderstood your need.

13
General Board / Defining the paragraph indent level
« on: July 27, 2017, 06:45:08 pm »
I have copied and modified the Use Case Details template that is provided with EA.

Having modified it for my purposes, some of the tables have different indent levels. In the output I can edit the indent level in Word and some are 0.48cm and others 0.95cm. Even removing the indent (by selecting Align Left) and then using "indent left" under paragraph, I cannot get the indent levels that have been used.

I cannot find the equivalent to the Word paragraph dialog where the indent level can be typed in precisely, which would allow me to type the indent amount.

Does anyone know how to set the precise indent?

All the lines have the same style.

14
I appreciate that this is an old topic, but I have the same issue - I want to include the Use Case diagram within my document as a child diagram of the Use Case. Not being able to include the diagram within the child elements section, I have generated a template that includes the Element Name in the heading, text extracted from specific parts of the Use Case element and the image of any diagram.

When it processes the child element it includes the Activity diagram, but also the auto-generated name of that, e.g. "Use Case_ActivityGraph", in my case as a heading one level lower.

In order to exclude documentation of all the elements on the Activity diagram, the best option that I have come up with is to use the option under the Structured Specification to generate an Activity with Action diagram. When I generate the document I use an Exclude Filter to exclude the elements I don't want to report on, e.g. Action, ActivityFinal, ActivityInitial, FlowFinal. (I have to use Activity with Action diagram - if I choose just Activity, then it is not possible to use a filter to separate the type of diagram from the type of element on the diagram).

Has anyone found a better way to include a Child Diagram?

What I would really like to avoid is the child Name appearing in my document output as well, but that appears because I am including the Element.Name, which is obviously wanted.

15
General Board / Re: Specific Diagram in Template
« on: May 25, 2017, 07:18:44 pm »
Do you need it to be dynamically generated from SQL?
If you need is satisfied by static diagrams then you can drag and drop the diagrams you want onto another diagram - Choose the Diagram Frame option when you drop it.

Pages: [1] 2