Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Nizam

Pages: [1] 2 3 ... 7
General Board / Re: BPMN Pool Properties are grayed out
« on: Today at 02:00:26 pm »
Glad it resolved. interesting that you don't see the option, there must be a 'Lock' option in context menu

General Board / Re: EA Sucks?
« on: Today at 01:54:51 pm »
Hi ... I am very concerned about how slow the EA tool generally is, but also much worse (and even impossible to use) depending on the location from which I login to our Intranet. Does EA have any built-in tools for capturing performance or measuring speed of response?

NB: Note I am not talking about complex scripts. Even just opening a view and creating a simple link between two elements, etc.

Also connecting via http (using Sparx Cloud service) offers form 40 to 50 percent improvement in performance for WAN  (this service includes WAN optimizer component as well).

Except for bulk XML exports / imports connecting via http is relatively better.

You can also try viewing locks from 'Manage Locks'  (Configure -> Locks (in Security)), if have rights for this, you can unlock the item

General Board / Re: multiselecting nested elements
« on: Today at 01:30:03 pm »
You can also consider using 'Diagram filters' to select items based on some criteria

General Board / Re: BPMN Pool Properties are grayed out
« on: Today at 01:27:51 pm »
Its locked by someone else, try applying lock in project browser, and it will tell you who has locked it

General Board / Re: Importing ERwin models
« on: Today at 01:26:30 pm »
Erwin allows you to export in EA recognizable XML, importing this in EA will create all entities its associations, subtype/ supertype, etc. But the diagrams will not be imported .
We need to create them manually, for subsequent synchronizations we use the MDG Office to export EA items as excel (with Synch Information), and have Excel extracts from Erwin mapped against it and import it back to EA using Import Excel (yes it is a bit of effort but we do it on a monthly refresh from Erwin)

General Board / Re: Issue with BPMN Pool and elements
« on: March 21, 2018, 11:37:39 am »
WHich version are you using. Is the Pool 'selectable'? and  the diagram editable. (and the Z Order is fine too)
AFAIK,  you must be able to resize Pools if the above two are fine. And also  you can place your Partitions to span over the elements to nest and move it slightly to make EA include the underlying elements (i.e. snap them).

In most cases, applying a different workspace layout restores key windows back to position. Its worth to give it a try.

Uml Process / Re: Enumeration of an Associated Name
« on: March 20, 2018, 08:08:04 pm »
You can define one in the local model in 'UML Types' -> Tagged Values.

General Board / Re: Academic Site Pricing Edition
« on: March 19, 2018, 11:12:30 pm »
Its usually Ultimate (If I'm not wrong)

Uml Process / Re: Enumeration of an Associated Name
« on: March 16, 2018, 10:11:12 am »
Target role, could be one of the attributes defined in the Target or a free text.
if I get your expectation right, you may be after a 'Enum' tagged value to the connector


Can you try a different name for your stereo and using that item from the UML profile.

Below works for me
<?xml version="1.0" encoding="windows-1252"?>
<UMLProfile profiletype="uml2">
   <Documentation id="0AA7F976-6" name="Sysml" version="1.0" notes="Sysml"/>
         <Stereotype name="myreq" metatype="myreq" notes="" cx="117" cy="79" bgcolor="-1" fontcolor="-1" bordercolor="-1" borderwidth="-1" hideicon="0" generalizes="SysML1.4::extendedRequirement" baseStereotypes="SysML1.4::extendedRequirement" redefines="SysML1.4::extendedRequirement">
               <Apply type="Requirement"/>
               <Tag name="ASIL" type="" description="" unit="" values="" default=""/>
               <RemovedProperty name="risk" description=""/>

EDIT - This could also be a version issue, i'm using 13.1 and the removed seem to work just fine

Good to know Paolo
Yes it is only one _subtypeproperty, i've created multiple metaclass instances to extend different stereotypes with hidden menus (albeit extending the same metaclass).

Best Regards

Hi Paolo
May be i'm saying something that you already know.

We can do that in the MDG definition. You need to add '_subtypeproperty' and set the tagged value (based on which you want your dropdown to work) as its initial value

which should look something like this in your MDG
Code: [Select]
<Apply type="Component">
<Property name="_subtypeProperty" value="IC::ICType"/>
<Property name="isIndirectlyInstantiated" value="true"/>
<Tag name="ICType" type="" description="" unit="" values="" default=""/>


General Board / Re: Custom Tag Search
« on: March 14, 2018, 10:56:10 am »
Are you sure its the same query that's causing this eror?  I have similar queries in my charts (SQL Server) and they seem to work fine.

may be this thread could help.

Pages: [1] 2 3 ... 7