Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Eamonn John Casey

Pages: [1] 2 3 4
1
Automation Interface, Add-Ins and Tools / EU GDPR MDG Technology
« on: April 11, 2018, 05:46:53 pm »
Hi!
This question is specific for people modelling information flows in preperation for compliance to the European Unions General Data Protection Regulation.

1. Is anyone using EA to model and document data flows for GDPR?
2. Anyone made or knows og MDG Technologies that can be used? I came on this one https://www.linkedin.com/pulse/gdpr-data-flow-mapping-approach-tim which is basically UML Activity.

Input appreaciated,
Eamonn J.

2
Hi,
I am using ArchiMate v3 and one of the things in the specification is placing a letter in the top left corner to signify which layer the element belongs to. I am New to schape scripting but don't know where to start.
I have added Project Template Package as in the documentation buut need now to change the script.

Thinking maybe something like:
Code: [Select]
drawnativeshape()
orientation = ne
print("A")

Which menu in Enteprrise Architect v13.5 need I be using?

Thanks,
Eamonn J.

3
General Board / Export elements from several subpackages to CSV
« on: February 18, 2018, 10:17:00 pm »
I have a package With subpackages containing elements. Is there a way to Select the parent package and export all elements in the subpackages to a CSV file? Some wort of SQL maybe?

4
General Board / Adding bends to existing connectors
« on: February 13, 2018, 11:27:48 pm »
I see that there is functionality to hold Down Shift while drawing a new connector. But is there a way to draw bends on existing connectors? I got loads of diagrams using the same connector and I only get to choose the defalut Routing types after the first diagram. Makes it very hard to make the diagram look pretty (and readable).

5
General Board / Using a central local help library
« on: February 01, 2018, 08:47:14 pm »
Is there any way in EA 13.5 to point to a Central help file? Our users run in a secure environment With no internet Access and no permissions to install software. Software gets pushed out to Virtual machines and I do not want to replicate help system for Our user base.

Thanks
Eamonn J.

6
General Board / Diagram Details hide when publishing
« on: January 16, 2018, 10:14:03 pm »
Hi!

Is there an option or setting where I can show Diagram Details in Enterprise Architect but when I copy to clipboard or publish that I can hide the details?

Eamonn J.

7
General Board / SQL to find mult connectors between to elements
« on: January 10, 2018, 11:04:40 pm »
Hi!
Does anyone want to share a nifty SQL that finds more than one Connector between to elements? Using "Hide Connector" and similar functionality has been a complete disaster for us. There are some pairs of elements in our model that have many connectors btween them. Makes creating New diagrams labourous to hide unnecessary eones.

I know the tables involved but not really a SQL guru!

Thanks,
Eamonn J.

8
Bugs and Issues / HTML Publish automation and the need to be logged in
« on: January 05, 2018, 07:40:15 pm »
I have made a utility to run the HTML Publish automatically on a Schedule but the user needs to be logged into the machine for it to work. Does anyone know of a workaround to make this work? I read about a Windows Service wrapper but that only seems to wrap my utility and not the Enterprise Architect instance.

What I really want is to be able to Reference models from Confluence where we do documentation.
Will WebEA/Pro Cloud help here?

Thanksin advance,
Eamonn J.

9
Bugs and Issues / ArchiMate 3 and Aggregation/Composition nesting
« on: November 14, 2017, 06:04:46 pm »
Hi!
I have noticed an issue With some elements in the ArchiMate 3 MDG when using Aggregation\Composition and Nesting. In some elements (Application Component) when putting one element inside the other the relationship should hide but it doesn't. Trying the same With elements in Stretagy or Motivation seems to work. The relationship hides when the elements are nested.
Eamonn J.

10
Automation Interface, Add-Ins and Tools / C# EA Wrapper available
« on: September 21, 2017, 09:17:10 pm »
If anyone wants it, I have been working on a wrapper for EA API in C#.
includes functions like:
Code: [Select]
EA.Element GetElementByName(int packageID, string elementName, string stereoType)
EA.Connector FindorCreateConnector(string fromElementGUID, string toElementGUID, string connectorDirection, string connectorStereoType)
EA.Element FindOrCreateElement(Package rootPackage, string elementName, string stereoType)
Package FindOrCreatePackage(Package parent, String packageToFind, String packageType)
List<EAQueryResults.EAConnector.Row> GetConnectorsByGuid(String fromGuid)

11
General Board / What is your top 10 features in EA 13.x
« on: September 21, 2017, 02:23:47 am »
Hello,
Been talking recently with a colleague. Couldn't agree on what cool things are in EA. Everyone can model, Swim Lanes and Model Views. Database Engineering and Cloud Pro/Web EA. But there is so much more.
Please post you favorites for the benefit of the community.
Eamonn J.

12
General Board / Pro Cloud/WebEA and log in (Single Sign On)
« on: September 13, 2017, 04:12:16 am »
Hello,

We got an EA 13.5 installation and have downloaded the ProCloud/WebEA trial. I got it to work in our local network but it seems that WebEA doesn't support Single Sign On. That I type in my Active Directory credentials.

I open Enterprise Architect normally with my Active Directory credentials. But from WebEA it doesn't accept my credentials. I must set the password in the EA client to something so I can use WebEA.

Is this a bug or an oversight. Or maybe it is a setup thing on the web server.

Anyone hit this problem?

EjC

13
Bugs and Issues / Nested elements and ArchiMate3::ArchiMate_Aggregation
« on: August 25, 2017, 08:00:13 pm »

Aggregation & Composition behave differently for nesting different elements. In the Application toolbox I create an Aggregation relationship between two elements and then place one inside the other. The line disappears. As it should according to specification.
If I do the same thing for Business Funstions the line does not disappear. Is there something in the MDG that I can modify so as to get this behaviour?

/ EjC //

14
General Board / EA Database structure verion
« on: August 24, 2017, 07:32:49 pm »
We have been running 12.1 and upgraded to 13.5. But seeing as I have only recently taken over admin of the database I don't know their version. Is there a way to find out which Version of the EA database I got?
I am thinking something simple like:

SELECT * FROM t_version

15
General Board / EA Swimlanes and custom Tagged Values
« on: August 24, 2017, 02:45:52 am »
Hi,
Has EA v13.5 lost the ability to Swimlane on Tagged Values? KanBan seems to have kept that ability and I do remember in v12.1 doing Swimlanes on custom Tagged Values.
Is there something I missed in the configuration og a Swimlane in v13.5?
Eamonn J.

Pages: [1] 2 3 4