Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Eamonn John Casey

Pages: 1 [2] 3 4
16
General Board / Security: Row Level Locking
« on: August 21, 2017, 06:51:55 pm »
I have a question about security in EA.
I have been reading about the addition of row level locking for EA. But I haven't really seen it. Neither in the released product nor in commitments to a future release. Can anyone shed some light on this???

/ EjC //

17
Automation Interface, Add-Ins and Tools / Scripting: Run button disabled
« on: August 18, 2017, 06:31:42 pm »
Hi,
Does anyone have an idea why my Run button is diabled in the Scripting toolbox? I am Administrator. In EA 12.1 it is enabled. In EA 13 it is disabled.
EjC

18
General Board / Automatic Color Elements based on Tagged Values
« on: August 18, 2017, 04:17:21 am »
Hello,
Hopefully someone has done this before and can help me out :)

I have been investigating Heat Map dashboards and they are really informative. What I would like to do is place elements (for example: ArchiMate Application Components) onto a diagram and based on Tagged Values to change the default color automatically.

I could do this with a script. But I don't want it to be a manual task. Maybe there is a "Before Display" event I could use to trigger the color change.

Any help would be appreaciated.

Thanks,
Eamonn J.

19
Uml Process / BPMN Import - Diagram does not draw correctly
« on: August 02, 2017, 08:24:47 pm »
Hi!

I recently got a BPMN file that was exported from CA Agile Requirements Designer. I am trying to import it into EA using Import XML / BPMN v2.0. It imports all of the elements but the diagram comes ou very strange. For example: Arrows don't Connect to boxes. They just stop in dead Space on the canvas.

I am guessing that the Bounds and Waypoint coordinates are the problem. That EA uses different geometry. Any suggestions on how to fix this?

Thanks for any advice
Eamonn J.

20
General Board / Cloud Server and RAS asset name
« on: June 19, 2017, 09:18:19 pm »
Hi,

Is there any way to find out the model name that was used to create a reusable asset?

Eamonn J.

21
General Board / Database Engineering: Remove Schema on import
« on: June 19, 2017, 08:54:02 pm »
Hi!

Got a question for reverse engineering a database that has Schema names (Oracle, DB2 etc.). Is there an option in EA to ignore the schema name on the import? What I am really trying to do is compare one live database schema to another lives schema.
Maybe I could just change it in the model? But I don't want to do that manually.

Thanks in advance
Eamonn J.

22
Hello,

Last week we encountered an interesting defect. For some reason the Parent_ID of a t_package got the same id as the Package_ID. This meant that it was a parent of itself. And of course dropped out of the Project Browser.
The solution was to og into the database and run an UPDATE SQL to reconnect it to a package in the Browser.

Has this been reported before?

Eamonn J. Casey
NAV  //  Arbeids- og velferdsdirektoratet

23
General Board / Database Builder: More than on connection
« on: June 08, 2017, 06:53:40 pm »
Hi!

Is there a recommended way to compare two live databases? We have a Development, test and Production database and I was thinking to use EA Database Builder to compare (for example) Development With test to generate an update DLL script.

How can this be done? Do I just change the database Connection element on the diagram?

EjC

24
Hi,

Does anyong know of an MDG Technology for the OMG Semantics of Business Vocabulary and Business Rules (SBVR)?

Thanks,
Eamonn J.

25
I am using this code to run a report but it keeps failing when the machine is logged off. Anyone have tried this and got it to work?

Thanks in advance.
Eaomnn J.

Code: [Select]
private static Repository repo = new Repository();
private static Project project;

repo.OpenFile2(options.SourceFile, options.UserName, options.Password);
project = repo.GetProjectInterface();
packageName = repo.GetPackageByGuid(options.Package).Name;
project.RunHTMLReport(options.Package, options.TargetFIle, "png", templateName, "html");       
repo.Exit();

26
Automation Interface, Add-Ins and Tools / Custom MDG ArchiMate and UML
« on: April 27, 2017, 11:43:02 pm »
Hope someone can help me With this.
I have create and MDG. Toolbox, diagrams and everything i working fine.
The issue that I get is when converting from my MDG to ArchiMate 3 to UML the Aggregation diamond changes direction.

I have a MetaClass that is an Extension of Aggregation. Setting the CompositionType has no affect. I also have the Generalisation to ArchiMate3::ArchiMate_Aggregation.

is there some trick attribute?

The reason I want to do this to be able to export from EA to other Tools that only support UML.

Thanks in advance,
Eamonn J.

27
Bugs and Issues / Cloud Services v13: Unable to connect to database
« on: March 31, 2017, 08:17:52 pm »
Hi!
I have configured Cloud Services v13. I have added a few Connections in the Client and enabled the "Allow Connections" option. On the EA Client v13 I try to Connect to the Cloud Server and get the error Message:
  Unable to connect to database

Do I still need to add ODBC System Connections on the server to connect to the database?

On a side note - how can I tell which models have been deployed?

Eamonn J.

28
General Board / Export XMI not 100% standard UML 2.1 XMI??
« on: March 23, 2017, 12:14:35 am »
I came across this statement when looking for import/export possibilities in EA With otherUML modelling Tools:

Quote
Enterprise Architect does not export 100% standard UML 2.1 XMI, and this causes some data loss during the import.

The Reference was to v7.1, 7.5 or 8.0. Is this still true for v12.1 & 13? Is there a niffty way I can check this out?

Thanks,


29
General Board / Resize Model when dropped on a Dashboard
« on: March 08, 2017, 11:54:37 pm »
I have created a Dashboard diagram and I want to display multiple models/diagrams on the same daashboard but the model image will not resize for me. It springs back to its original size when I try. Is there another way to resize the image?

Thanks,
Eamonn J.

30
General Board / New Cloud Services: Publishing Feature
« on: March 08, 2017, 10:05:40 pm »
Hi!

This is probably a question for Sparx Support. But is it possible to run the publish feature in the up and coming new Cloud Services as a Windows Service ?

We currently have problems with this line of code because the user must be logged in to run it and Our server guys automatically log stale sessions as a policy:

Code: [Select]
project.RunHTMLReport(options.Package, options.TargetFIle, "png", templateName, "html");

Pages: 1 [2] 3 4