Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - PeterHeintz

Pages: 1 [2] 3 4 ... 9
16
What is the difference between an action pin “Classifier” an action pin “Type” and an action pin “Behavior/Parameter”?

When you drag an Activity with classified parameters as Invocation (Action) with “Structural Elements=All” action pins are created.

When selecting an action pin on the diagram, in “Element Properties/Element” you see under Advanced in property “Classifier” “name:Classifier” fitting to the parameter of the activity. Further on, in “Element Properties/Pin” you see under “Argument/Parameter” the right activity parameter for the pin. However the "Type" of the pin is empty.

When you do the same Parameter/Pin synchronization later by “Element Properties/Behavior”, in addition to the “Classifier” and “Argument/Parameter” properties the "Type" property is set as well.
Further on you are allowed to set the "Type" to something different as “Classifier”/“Argument/Parameter”.

In this case, the properties “Classifier” and “Argument/Parameter” point to the Activity parameter but the Type of cause not. In the diagram, the pin label part showing the classifier, shows the type rather than the “Classifier”/“Argument/Parameter”.

And finally you can even change the “Classifier” to something else to get a pin:
Having Classifier A, Type B and Parameter Argument C 

What is the sense of all that?

This or similar stuff exists in V13 as well.

17
When you have an Activity with unnamed but classified parameters and you drag and drop it in a activity diagram as an “Invocation (Action)” with “Structural Elements= None”, and you press “Synchronize with Parameters” in “Element Properties/Behavior” all parameters (named and unnamed parameters) get pins on the action.

But in cases of unnamed parameters the error message “Encountered an improper argument” is shown (I even saw an EA crash).

Further on, even unnamed parameters are now show with labels, but “Call.:Classifier”
From my perspective the label should be ":Classifier".

18
When you have an Activity with unnamed but classified parameters, and you drag and drop it in a activity diagram as an “Invocation (Action)” with “Structural Elements” (Parameters -> Pins).

These pins do not have any label, neither name nor classifier.

Once a “Space” is added as name of the Parameter the pin gets the label “Space”:Classifier.

Showing the classifier within the label of the pin, should not depend on empty/not empty names of the parameter!

19
When you have an Activity with named and unnamed but classified parameters, and you drag and drop it in a activity diagram as an “Invocation (Action)” with “Structural Elements = All”, only one but not “All” of the unnamed but classified activity parameters are copied as action pins.

20
When you have an Activity with several parameters and you drag and drop it in a activity diagram as an “Invocation (Action)” with “Structural Elements = Select….” No activitiy parameters can be selected.

21
When you try to create a SysML1.5 diagram under “Activity, Block Definition, Requirement, State Machine”, the different diagram kinds offered are prefixed with SysML1.4 rather than SysML1.5.

seen in Build:1413

22
After having assigned a state machine via Instance Classifier to a state, it is not anymore possible to select a Composite Diagram to this state.
Remark: Same problem exist for actions later made to callBehavior
Seen in Build 1310 and others

Reported!

23
General Board / EA V14 Beta; What about SysML1.4?
« on: March 13, 2018, 12:59:33 am »
Today I had a first look on EA V14 Beta.
I realized that SysML1.4 is missed. Will SysML1.4 not be supported anymore?

24
Bugs and Issues / Link to Element Features not working on properties
« on: February 28, 2018, 12:31:18 am »
When using “Link to Element Feature” in field “Feature Type” you can select value “properties”. However in the Feature list below not properties are listed even if the element has properties. So it is not possible to link properties at all.

Reported!

25
General Board / Virtual Documents and RTF Templates
« on: February 16, 2018, 04:25:42 am »
Hi,
Can anyone enlighten me, how I can use RTF templates for virtual documents. Up to now I did only use virtual documents for html.

I have a rtf-template that works fine on packages.

Now I created a <<report package>> having one <<model document>>.
My first try was to add a tag RTFTemplate to my <<report package>> manually and setting the value to point to my working template.

As a result I got a cover page as expected but all the content was rendered with the system “Model Report” template. I fiddled around with both RTFTemplate tags (<<report package>>, <<report package>>), but whatever I do I get my stuff only rendered with chatty “Model Report”!?! :'(

26
When defining queries of diagrams with the Query Builder, each row of the returned results shows the right diagram type icon and double click to a row opens the diagram.

When you do the same with SQL and using t_diagram.ea_guid as CLASSGUID and t_diagram.Diagram_type as CLASSTYPE the wrong icon is shown and double click does not work. Double click starts opening the right diagram after a “Find in Project Browser” is done row per row.

Further information:
http://www.sparxsystems.com/forums/smf/index.php/topic,39165.0.html

27
General Board / Another question about SQL queries of diagrams
« on: January 26, 2018, 01:46:46 am »
I want to have my query result clickable so that I can easy move to the diagram.

This works for queries created with the query builder. But what fields I have to alias with CLASSGUID and CLASSTYP when I do pure SQL on t_diagram?

28
General Board / EA Repository Table; How to get diagram types?
« on: January 25, 2018, 11:20:21 pm »
Up to now my diagram queries had been simple enough to use the query builder.

But now I need sql and I want to filter to concrete diagram types like BDD or IBD.

The t_diagram table has a Diagram_Type field but only containing abstract types like Logical, Package,… but not the concrete once.

T_diagramtypes is also not helpful, so I tried to use the magic “description” field in t_xref. This field contains some diagram field information but I do not know how to connect to.

Does anyone know in which field and table the concrete diagram types are stored and how this table is connected to t_diagram.
Is it t_diagram->t_object->t_xref?

29
I have created some search queries (located in My Searches) and I have some Views in a View Folder (let’s say MyViews) pointing to searches in My Searches.
Once I published and import a MDG which contains My Searches and MyViews in another project, I find the punished searches under a search container with name let’s say is “My MDG” and the "views" whithin a top level Model Views folder “My MDG”.

However the search folders within my imported "Model Views" still point to “My Searches” rather than to “My MDG” searches.

Trying out the trick to import the MDG to the source repository of the MDG to point to “My MDG” searches before publishing (what I do with success in some other scenarios) does not work here for whatever reason.

Any idea how to solve that with MDG?

30
Bugs and Issues / RTF Template Selectors based on package stereotypes
« on: October 24, 2017, 09:14:55 pm »
Does anyone know if this should/is work.

Package:review session:KB-SfS ESC ReviewSessionPackages
Package::KB-SfS ESC Packages

Currently I assume that this is just another issue, where package elements are constraint without reasons.

Pages: 1 [2] 3 4 ... 9