Topics
Prev Next

General Questions

This topic provides answers to a number of questions that new users commonly raise when starting to work with Enterprise Architect.

Question

Answer

See also

How do I update to the latest release of Enterprise Architect?

Updating your existing version of Enterprise Architect to a later version (for example, updating Enterprise Architect 12.1 to Enterprise Architect 13) requires your subscription to be current. If your subscription is current, you can download the latest installation executable from the 'Registered User' page of the Sparx System website.

If your subscription has lapsed, you must purchase a subscription renewal to access the latest version of Enterprise Architect.

Once you have downloaded the new installation executable, the existing version of Enterprise Architect must be uninstalled. Running the new installer will help you do this automatically, as you follow the prompts, or you can uninstall your existing version manually beforehand via the Windows Control Panel.

Registered User Site Subscription Renewal

'This app can't run on your PC' error message appears when attempting to install Enterprise Architect on Windows 10.

The installer might be corrupt. Try clearing your Internet browser cache and downloading the installer again from the Sparx Systems website.

An Error has Occured: Couldn't lock file - when using .eap files

This error typically occurs if you do not have full read/write access to the folder that contains the .EAP file. Please check permissions on the .EAP file and the permissions of the folder it is located in.

Alternatively, try copying the file to a location where you have full read/write access (e.g. My Documents) and open it from there.

Can I use a .eap file for a large Repository?

It is recommended that you use a DBMS repository for a large and/or multi-user project.

The file format for .eap files is MS Jet 3.5, and for .eapx files is MS jet 4.0. This format, although very efficient for small repositories and for a small group of users, does create issues for larger repositories above 40 megabytes, or for user groups above 5 simultaneous users.

For more details see page 4 of the Deployment of Enterprise Architect white paper.

Deployment of Enterprise Architect

Can I migrate my personal Enterprise Architect settings from one installation to another?

Most local settings for Enterprise Architect are stored either in the Windows Registry or in the file system below the %APPDATA% directory of your current user profile. To export your settings:

1) Run regedit.exe and export the following registry key

         [HKEY_CURRENT_USER\Software\Sparx Systems\EA400]

2) Copy all files from the directory

         %APPDATA%\Sparx Systems\EA

     (Note: %APPDATA% by default refers to the directory C:\Users\%username%\AppData\Roaming\Sparx Systems\EA)

Exporting these registry settings and copying the files from Application Data should allow you to transfer most of the local settings.

Can I use Windows Active Directory?

You can import your Windows user IDs from Windows Active Directory and use them as the security user IDs with Windows Authentication.

For more details refer to the Notes section of the Import User IDs From Active Directory Help topic.

Import User IDs From Active Directory

How can I share Search Definitions with other users?

You can use the 'Export Search' and 'Import Search' functions to make searches available for other users. For more details refer to the Model Search Help topic.

There is no option specifically to save search definitions within the Project; however, you can still effectively achieve this by creating an MDG Technology which includes your search definitions and then importing this back into your Project as follows:

  1. Create an MDG Technology that includes your search definitions (refer to the Create MDG Technology File Help topic).
  2. Import the MDG Technology into your Project (refer to the Import MDG Technologies to Model Help topic).
  3. In this case the MDG Searches should be automatically available to any user who opens the Project. The MDG Technology should be enabled by default; however, if necessary a user can disable/enable it via the 'MDG Technologies' dialog (refer to the Manage MDG Technologies Help topic).

Alternatively, if you are using SQL queries you could consider creating some Model View elements that display the results of your queries on diagrams. For details refer to the Define a Model View Chart Help topic.

Define a Model View Chart Import MDG Technologies to Model Create MDG Technology File Model Search Manage MDG Technologies

I reported a bug. Can I follow my issue on the web?

We do not provide any public bug tracking facility. If you have any enquiries regarding a previously reported issue, please email support@sparxsystems.com along with the reference number for your previously reported issue.

Sparx Systems Forum - Latest News

Why am I missing menu commands?

Enterprise Architect provides customizable menu sets which hide specific items to help improve workflow based on your role. If you seem to be missing menu items, it is possible that you have selected a menu set which hides those items.

To correct this, Open: Start > Workspace > Perspectives > Show Perspectives Window > Menu Sets.  To show all available menu options, select the 'Complete' menu set.

For more details refer to the Menu Sets Help topic.

Menu Sets

Can I transfer a Relationship Matrix Profile to another project?

It is not possible to export a Relationship Matrix profile as reference data; however, you can still effectively import/export Relationship Matrix profiles in the following ways:

1)  Create a hyperlink on the diagram, set its Type to 'Matrix' and select the matrix profile you want to share. Export the Package containing this diagram to XMI. The matrix profile will be saved within this XMI. You can then import this Package (including the matrix profile) into other Projects.

2)  Alternatively, create a Matrix Specification element. This automatically creates a new Matrix Profile matching the element name. If you export/import this element via XMI into another Project then the Matrix Profile will also be included.

Artifact Toolbox XMI Import and Export

How do I copy diagrams or diagram elements?

There are several options available for copying diagrams and diagram elements. Diagrams and their entire contents can be copied via a deep copy, or you can copy the diagram while still linking to the same original elements via a shallow copy. For more details refer to the Copy (Duplicate) Diagram Help topic.

Copy (Duplicate) Diagram

How can I copy a Package or element tree?

You can easily copy a whole Package-tree or an element-tree to another location in the current repository or into another repository opened in another instance of Enterprise Architect. For details refer to the Copy a Package Help topic.

Copy a Package

What Tables can be used in a SQL Model Search?

When writing a query Ctrl+Space will display the intellisense dropdown menu, which provides a list of all available tables. You can see the full content of a table with a query such as:

     select * from t_object

In addition to this, you can refer to the Enterprise Architect Object Model, Reference section of the Enterprise Architect Help. This describes the objects available to the Enterprise Architect Automation Interface. In most cases the Classes and attributes correspond directly to Tables and columns in the database. For example, the Element Class Help topic mentions that the associated table is t_object.

Reference Element Class

Do you support older versions of Enterprise Architect?

Sparx Systems officially support only the latest release of Enterprise Architect. However, if you have questions or issues concerning an earlier release we will still assist you. Note that we do not provide patches for earlier releases of Enterprise Architect. If you are experiencing a problem with Enterprise Architect that has been fixed in a later release you would have to upgrade to the later release.

On opening a repository I am getting a default diagram - how to disable this?

A default diagram has been set on the project, using this option:

     Ribbon: Layout > Diagram > Manage > Set as Model Default

You can cancel the default in this way:

  1. Create and open a new diagram.
  2. Select the ribbon option: Layout > Diagram > Manage > Set as Model Default.
  3. Delete the new diagram.
  4. Reload the project.

How do I troubleshoot performance issues with DBMS repositories?

Performance issues are commonly related to your DBMS repository setup or network access to this repository.

This series of steps will help identify and resolve a number of performance issues:

1. Have you tried running a project integrity check on the model?

     Ribbon: Manage > Model > Check Integrity > Project Integrity

2. Do you have auditing enabled on the model?

     Ribbon: Manage > Model > Audit > Audit Settings > Enable Auditing

Auditing is a feature that can have a significant effect on a model's performance. If Auditing is enabled, try turning it off to see if there is any improvement in performance.

3. Do you have any Add-Ins enabled? What happens if you temporarily disable them?

     Ribbon: Specialize > Add-Ins > Manage

4. If you are using a DBMS repository via ODBC or a Cloud Service, you can check the response from the server using a Windows CMD | ping of the IP address of the server. For example:

     ping 192.168.0.12

If the response time is greater than 10ms for an ODBC connection to a DBMS based repository, the network is probably the issue and you should consider using a Cloud-based connection to the DBMS.

With the Cloud service the latency range for reasonable performance can be up 150 ms. If the general ping response is greater than this, you would need to reconsider using the Cloud service over such a slow WAN connection, and possibly consider using an alternative, like DBMS-Replication, if your DBMS supports this.

Auditing The Add-In Manager Check Project Data Integrity

How do I restore the scroll bars in the Project Browser?

Newer Visual Styles such as Microsoft Visual Studio 2012, Microsoft Visual Studio 2013 or Microsoft Office 2016 will hide the horizontal scroll bar and use the auto-scrolling behavior.

You can disable auto-scrolling and restore the scroll bar by resetting Enterprise Architect to use an older Visual Style such as Microsoft Visual Studio 2010; select:

     Ribbon: Start > Workspace > Visual Style

Select the appropriate style.

Visual Styles