Sparx Systems Forum

Enterprise Architect => Automation Interface, Add-Ins and Tools => Topic started by: David Rains on March 29, 2019, 12:41:49 pm

Title: UML Profile - Everything is displayed as Package and drop as a ST Class?
Post by: David Rains on March 29, 2019, 12:41:49 pm
Using EA 14.1 (Just upgraded, was using 13.5)

Problem 1: All of my stereotypes are being displayed as 'Packages' in the 'Loaded Profile' and regardless of stereotype selected (attribute, operation, class, package) they are ALL sterotyped 'Classes' when I use the profile created from the Package

Problem 2: Created from Diagram (... displayed as 'Packages", but unable to drag to diagram...)

I created them the way I always have (Drag stereotype and name it, drag metaclass, connect stereotype to metaclass with extend), tried using create profile (as package and as diagram) using "new" ribbon method (specialize, publish as...)...

I also noticed that I have to add ".xml" to the file name otherwise it is NOT being saved as an XML file (? e.g. not reconginized by Win 10 as XML file, just 'file")

Seems like this would have come up in the search IF THIS WAS A BUG.... Is the world just after Bioform for upgrading to 14.1?  :)

<?xml version="1.0" encoding="windows-1252"?>
<UMLProfile profiletype="uml2">
   <Documentation id="E372ADF2-C" name="TestAsDgm" version="" notes="TestAsDgm"/>
   <Content>
      <Stereotypes>
         <Stereotype name="asAtrb" notes="" cx="90" cy="70" bgcolor="-1" fontcolor="-1" bordercolor="-1" borderwidth="-1" hideicon="0">
            <AppliesTo>
               <Apply type="Attribute"/>
            </AppliesTo>
         </Stereotype>
         <Stereotype name="asCls" notes="" cx="90" cy="70" bgcolor="-1" fontcolor="-1" bordercolor="-1" borderwidth="-1" hideicon="0">
            <AppliesTo>
               <Apply type="Class">
                  <Property name="isActive" value=""/>
               </Apply>
            </AppliesTo>
         </Stereotype>
         <Stereotype name="asOpr" notes="" cx="90" cy="70" bgcolor="-1" fontcolor="-1" bordercolor="-1" borderwidth="-1" hideicon="0">
            <AppliesTo>
               <Apply type="Operation">
                  <Property name="isOrdered" value=""/>
                  <Property name="isQuery" value="false"/>
                  <Property name="isUnique" value=""/>
                  <Property name="lower" value=""/>
                  <Property name="upper" value=""/>
               </Apply>
            </AppliesTo>
         </Stereotype>
         <Stereotype name="asPkg" notes="" cx="90" cy="70" bgcolor="-1" fontcolor="-1" bordercolor="-1" borderwidth="-1" hideicon="0">
            <AppliesTo>
               <Apply type="Package">
                  <Property name="URI" value=""/>
               </Apply>
            </AppliesTo>
         </Stereotype>
      </Stereotypes>
      <TaggedValueTypes/>
      <ViewDefinitions/>
      <Metamodel/>
   </Content>
</UMLProfile>


David
Title: Re: UML Profile - Everything is displayed as Package and drop as a ST Class?
Post by: Geert Bellekens on March 29, 2019, 03:27:24 pm
You seem to be missing meta class extensions.
Use the profile helper to select the meta class.

Geert
Title: Re: UML Profile - Everything is displayed as Package and drop as a ST Class?
Post by: David Rains on March 29, 2019, 03:41:57 pm
Okay, so I did some other work on my new laptop, reopened the EA 14.1 file and it is fine?! <sigh>