Sparx Systems Forum

Enterprise Architect => Automation Interface, Add-Ins and Tools => Topic started by: Greenbolt on October 22, 2019, 12:09:01 am

Title: V15 Scripts do not run
Post by: Greenbolt on October 22, 2019, 12:09:01 am
Good morning everyone,

I removed V14 and installed V15 and since then I can not execute scripts anymore. Does anyone have any suggestion as to why that could be happening? This happened only with V15 so far and when I downgrade to V14, scripts execute just fine.
Title: Re: V15 Scripts do not run
Post by: Geert Bellekens on October 22, 2019, 01:21:37 am
Maybe you don't have "execute script" rights?

It's one of the newer user security rights, and it's not enabled by default.

Geert
Title: Re: V15 Scripts do not run
Post by: Takeshi K on October 23, 2019, 11:37:46 am
Hello Greenbolt,

Maybe you can avoid the issue by installing Visual C++ Redistributable for Visual Studio 2015.
https://www.microsoft.com/en-us/download/details.aspx?id=48145
(You need to download 32bit file.)

HTH,
Title: Re: V15 Scripts do not run
Post by: Rich Anderson on October 23, 2019, 03:04:52 pm
Hi Greenbolt,

This might be related to the issue I reported with EA15 where it was locking.  Sparx has investigated this, contacted me, and confirmed they were able to duplicate the problem..  In my case, EA15 would lock up when my external VB.NET program would start EA.  This does not happen with EA14.   

https://www.sparxsystems.com/forums/smf/index.php/topic,43305.msg256831.html#msg256831

Maybe this will help you...
Title: Re: V15 Scripts do not run
Post by: peterc on October 24, 2019, 08:16:11 pm
I had the same and with some diagnosis from Sparx I identified two DLLs that were missing: MSVCP140.dll and VCRUNTIME140.dll.

I found those elsewhere on my computer and copied them to the EA install folder, resolving the issue.

I've also since had a follow-up e-mail from Sparx:

The issue has been confirmed and will be investigated further by our development team. It looks like mozjs-63a1.dll requires the DLLs that you mentioned.

As a workaround we recommend downloading the x86 VS 2017 runtime files from Microsoft.
https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads
Title: Re: V15 Scripts do not run
Post by: Takeshi K on October 24, 2019, 08:34:29 pm
Hi all,

Just for your information, MSVCP140.dll and VCRUNTIME140.dll are included in the Visual C++ Redistributable for Visual Studio 2015, which I mentioned in the above post.

Copying the files might works fine, but it is better to use Microsoft official installer to avoid further missing related files.

HTH,