Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Erlenmeyer

Pages: [1] 2
1
General Board / Re: Relationships in multiple diagrams
« on: November 02, 2019, 12:24:20 am »
Is there a way to show relationships in the Project Browser?

2
General Board / Re: Relationships in multiple diagrams
« on: November 02, 2019, 12:17:45 am »
Thank you Peter. My sample scenario was very simple to illustrate the problem. In reality, I have a very large set of models in my project and there are many relationships between elements that are included on many diagrams. I can select an element and see the list of relationships in the "Trace-->Relationships" window, but it doesn't show which diagram(s) the relationship is on. If I delete one, I won't know what other diagrams were affected.

3
General Board / Relationships in multiple diagrams
« on: November 01, 2019, 02:05:27 am »
Hello,

Here is a very simple scenario:
Two elements appear on two different diagrams.
A relationship is shown between the elements on both diagrams, but they are not the same relationship -- they are duplicates. How can I identify the duplicate one so it can be deleted from the model?

I haven't gotten the relationship matrix to work, probably due to how I have the elements packaged separately from the diagrams -- I created packages to hold elements according to business function (a portfolio of elements) and I drag them to a diagram when needed, so they are not in the same packages as the diagrams.

I can highlight an element and use "Trace--> Relationships" which lists all of its relationships, and I can click on each one to find where it is in all the diagrams, but that doesn't really show me which are the dupes. It  would be great if the Relationships list showed the diagram names, then the dupes would be obvious.  OR, if I could add alias' to the Relationships list, then I can assign an alias to each relationship.

I would love to have a matrix of all relationships between all elements in my entire model, but the model is very large with hundreds of relationships.

Any ideas?  Thanks in advance

4
General Board / Expose Interface not working
« on: August 02, 2019, 02:38:31 am »
The R14 user guide says:

"When you create the Expose Interface element, a dialog displays in which you enter a name for the element and specify whether it represents a required interface or a provided interface."

When I drag the "Expose Interface" element onto a Participant, I do not get the dialog box -- the element is always created as a "provided interface."  How do I create a Required Interface?

The "Assembly" connector seems to create both interfaces, but the user guide still doesn't match what I am seeing when using the UML component Expose Interface

I am working on a SoaML Services Architecture, BTW.  I don't necessarily want to create a "SOA - Services" "Service Interface" element in every case where I want to model an interface.

Mark

5
"Think presentations to the C-suite in your choice of presentation software"
This is why my team has lost its dignity and is using PowerPoint for executive presentations.

6
You need to display the Diagram Properties DIALOG and select the Connectors page. The last item on this page is the Connector Notation field.

To display the dialog, right-click on the background of the open diagram and select the Properties option.

In the "Entity Relationship", "Simple Entity Relationship Model" the connectors properties,  is already set to "Information Engineering." Relationships are still represented with diamonds and attributes as ovals. Takes up too much room on the diagram and looks terrible.

We can make "Data Modeling" work. It is under "Business Modeling" "Modeling" "Data Modeling" exactly where I would expect it to be -- sorry for being sarcastic.

I hope BABOK is included in the Corp Edition, because I am the only one with Ultimate.

7
Your data modeler deserves a kick in the butt if that is really the reason he refuses to use EA.
That was more or less what I wanted to say. I could understand someone saying they think a tool is too hard to use or doesn't do everything they think it should. But if you're told to use a particular tool anyway, you find a way to make it work. (And that applies even if you're being directed away from Enterprise Architect)

He reports to me and promised to give it another try. He has a deadline to meet.

All of my architects are finding the Sparx learning curve a challenge, so I am prebuilding some models and then turning them over. I told the team I do not want to see another PowerPoint of Visio diagram -- although these are more effective in presentations to stakeholders.

There are some things I find odd about Sparx, such as the "Save" button being on the "Layout" tab. Not intuitive at all.

8
EA is not a database modeling tool. It's just a "me too" functionality of an UML modeling tool. If you need a hammer don't buy a pair of pliers.

q.

Agreed. Sparx EA does everything but only does UML well.

9
I agree 100%
I can't get my data modeler to use Sparx!

10
diagram properties | Connector | Connector Notation

I don't see this option in "Diagram Properties."  I am using R14.
My data modeler refuses to use Sparx due to the way relationships are represented. He wants crows feet. He downloaded Oracle data modeler and is happy.
Doesn't make me feel good about the $2K we spent on Sparx licenses.

11
We moved to a Sparx Cloud solution with models in MS SQL databases. The server needed some tuning and upgrade, but the performance is tolerable.  File-based option was not adequate for us, especially if MS Access is the underlying DB!

12
General Board / Re: How to rename a model
« on: June 12, 2018, 05:22:01 am »
I normally create a root node with the name I want to use. But after the  root node is created, you can't change its name either.

13
General Board / Re: Import EA4BI into EA v14
« on: May 18, 2018, 11:31:02 pm »
This MDG technology product is WONDERFUL!   We needed BI and ETL modeling as well. Thanks Rudi

14
General Board / Re: Import EA4BI into EA v14
« on: May 18, 2018, 11:08:26 pm »
Thank you Rudi and Sparx,

Either way seems to work:
    1. Tiny search field on "Home" pulldown to the left of "Start" tab
    2. Specialize > Technologies > Publish > Import UML Technology

I had to select "Import to User" -- "Import to Model" didn't seem to work

The remaining steps I followed are:
1. In Model Wizard, I had to select the "Diagram" tab
2. "Select From" pull-down, select "My Perspectives"
3. Select "EA4BI"
3a.Check "Create Package"  not checking this didn't seem to work
4. Select desired diagram
4a.   Package and diagram are created
4b.  Toolbox contains the appropriate elements and stereotypes

Comments on the design of the product:
Finding  "Import MDG Technology and under "Specialize->PUBLISH" is not intuitive. It made more sense in v13.5 to have it under "Extend"

I am now finding joy in building MDM diagrams.

Thanks again,
Mark

15
General Board / Re: Import EA4BI into EA v14
« on: May 16, 2018, 02:52:27 am »
Rudi,
Thank you for being patient and helping out.

I am using EA v14. Your instructions seem to apply to v13.5.  There appears to be no "Extend" option any longer in v14.
To restate:  the only way I can see to import MDG in v14 is .MDZIP file or .xmi.
Your EA4BI is a .zip containing a .xml file.
Mark

Pages: [1] 2