Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Erlenmeyer

Pages: [1]
1
General Board / Relationships in multiple diagrams
« on: November 01, 2019, 02:05:27 am »
Hello,

Here is a very simple scenario:
Two elements appear on two different diagrams.
A relationship is shown between the elements on both diagrams, but they are not the same relationship -- they are duplicates. How can I identify the duplicate one so it can be deleted from the model?

I haven't gotten the relationship matrix to work, probably due to how I have the elements packaged separately from the diagrams -- I created packages to hold elements according to business function (a portfolio of elements) and I drag them to a diagram when needed, so they are not in the same packages as the diagrams.

I can highlight an element and use "Trace--> Relationships" which lists all of its relationships, and I can click on each one to find where it is in all the diagrams, but that doesn't really show me which are the dupes. It  would be great if the Relationships list showed the diagram names, then the dupes would be obvious.  OR, if I could add alias' to the Relationships list, then I can assign an alias to each relationship.

I would love to have a matrix of all relationships between all elements in my entire model, but the model is very large with hundreds of relationships.

Any ideas?  Thanks in advance

2
General Board / Expose Interface not working
« on: August 02, 2019, 02:38:31 am »
The R14 user guide says:

"When you create the Expose Interface element, a dialog displays in which you enter a name for the element and specify whether it represents a required interface or a provided interface."

When I drag the "Expose Interface" element onto a Participant, I do not get the dialog box -- the element is always created as a "provided interface."  How do I create a Required Interface?

The "Assembly" connector seems to create both interfaces, but the user guide still doesn't match what I am seeing when using the UML component Expose Interface

I am working on a SoaML Services Architecture, BTW.  I don't necessarily want to create a "SOA - Services" "Service Interface" element in every case where I want to model an interface.

Mark

3
General Board / Import EA4BI into EA v14
« on: May 12, 2018, 12:58:58 am »
I was looking for a MDM modeling solution for one of my architects and found EA4BI. I can open the sample model -- which is exactly what I have been looking for -- but v14 doesn't seem to support the same import MDG extension as v13.5.

The instructions https://community.sparxsystems.com/tutorials/1126-getting-started-with-ea4bi explain how to import the .XML file, but v14 will only allow .MDZIP and .XMI files.  Am I missing something?  or do I need to start with the sample EA4BI model for each MDM project I have my colleague work on?

Thank you ...

4
Installed 13.5 (Ultimate) and the MDG packages. I get the subject error message. Uninstalled TOGAF and Zachman, and reinstalled one by one.  The issue seems to be in the Zachman package, but I can't open sample projects for SysML, Zachman, or TOGAF. UPDM works ok.

I searched the history for this issue. It was reported in 2014 and apparently, not fixed.

Related issue?
When opening the SysML sample project, I get "An error has occurred: The Microsoft Jet database engine cannot open the file ...  It is already opened exclusively by another user or you need permission to view its data."

I had the Trial version installed previously but removed it before installing the purchased version. Any leftovers from trial causing this?

5
General Board / Mimicking "Getting Started" page
« on: March 08, 2018, 01:05:25 am »
I like how the "Getting Started" page contains boxes that can be used. How can I create navigation pages like these?

6
General Board / Archimate - Can't move elements between packages
« on: February 23, 2018, 05:15:41 am »
Hello,

I did a search but didn't find anything that addressed my specific issue. Maybe it is unique to Archimate model elements.
I created a hierarchy of packages because I have hundreds of application components. How can I move an element out of one package and into another?  I see the package name in the properties, but it is not editable. Trying to drag and drop only opens the properties dialog.

Thanks!

Pages: [1]