Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - bkone

Pages: [1]
1
General Board / Extending ArchiMate Elements (Attributes and Shapescript)
« on: October 19, 2021, 01:27:51 am »
Hello all,

I'm in the need to capture data for ArchiMate elements (e.g. Application Component: Security Rating, ...) and hence created a custom non-UML profile (generalization from ArchiMate stereotype, extension from meta class) - no MDG (yet).
Coloring was also successful (coloring the stereotype).
As I want to adhere to the naming layed out in Gerben Wierda's famous Mastering ArchiMate, I also want to show a custom name on the shapescipt.
Idea:
- use standard name attribute
- add "group" attribute
- show "
[<group>]
<name>
(<metatype>)
" on elements in diagrams.

Question would be now if I have to create a completely new shapescript (based on the one in Geerts library on github) or can overwrite only certain parts of the shapescript.
To my current knowledge I think, I have to go the first solution.


Best regards

Boris
 

2
Bugs and Issues / Error Message when opening a Cloud Connection
« on: May 03, 2021, 10:44:21 pm »
Hello all,

we have set up a recent Enterprise Architect 15.2.1559 on a desktop PC to access a ProCloud repository.
After filling in the fields for the cloud connection in the dialog we get a popup with the following message:

Pro Cloud Server: Unable to connect to service
Pro Cloud Server: Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch.
(English translation: Pro Cloud Server: The syntax for filename, folder name or disk name is wrong.)

I have never seen this message and anything we do doesn't solve the issue.

What works:
- We can successfully access the URL of the repository with a browser from the desktop PC.
- This repository could be successfully accessed by already installed EAs on several laptops in the company.
- Creating a local repository on the desktop PC works.

I'm out of ideas ..


Best regards

Boris

3
Bugs and Issues / Black Boxes instead of Tooltip
« on: April 27, 2021, 10:28:46 pm »
Hello all,

in EA version 15.2-1559 on latest Windows 10 I do get black boxes instead of tooltips shown.
Any ideas on this one?


Best regards

Boris

4
Hello all,

I have difficulties to identify if a diagram or element is from UML.
With BPMN or ArchiMate I can use the element.FQStereoType or diagram.StyleEx (looking for MDGDgm=xxx;).
But in case of UML all those attributes are empty.

Any idea on how I can identify those UML diagrams and elements?


Best regards

Boris

5
Hello,

I can reproduce crashes with my scripts in 15.2.

Environment:
- EA: 15.2
- EA-Matic
- Scripts in VBScript

The scripts are triggered on events to populate data at elements or style diagram objects.
If I start EA fresh and start modeling, then after adding some elements/diagram objects it show an error message "Out of memory" and after a few more additions it crashes without further notice.

Is there a somewhere a log? Be it from EA or Windows?
Any ideas on how to narrow this down?


Best regards

Boris

6
Hello together,

I'm trying to use the EA-Matic to handle events when a new diagram object is created.
Unfortunately I do get an error when reading the object ID like this:
(I have looked up the correct parameter name on github)

function EA_OnPostNewDiagramObject(Info)
   dim diagramObjectID
   set diagramObjectID = Info.get("ObjectID")
end function

Any ideas what I'm doing wrong here?
Can someone point me to the correct attribute name?


Best regards

Boris

7
Hello together,

I'd like to denote which Data Objects are transferred across a relationship in ArchiMate. I'm using EA 15.1 to create the model.
Example: Business Function A --Data Object--(Flow)--> Business Function B

I can connect the two Business Functions with a flow relationship, but I'm unable to create the additional association between the Data Object and the Flow relationship.
I already disabled already the "Strick Connector Syntax" in the preferences
Am I missing here something on how this could be done in EA?
Or is this not supported by EA? According to the standard of ArchiMate 3 this should be possible.


Best regards

Boris

8
Hello all,

I tried to find some information in the forum on the mentioned topic, but I wasn't successfull.
If this topic was discussed before, just point me to the messages/threads.

I will create in the next future extensive scripts to handle ArchiMate modelling. Unfortunately EA support modelling, but falls short on analysis features. Hence, I have to create them ...
I played a bit with EA-Matic as I like the scripts approach more that going full in on DLL development.
Currently I have the following questions marks above my head:

- Why is EA-Matic complaining (not seeing the scripts) if I start using typed variables instead of just object?
For example: dim element as EA.Element
This would be helpful to use the suggestions in the editor.

- Only one script to handle the menu?
I tried to have multiple scripts contributing to the menu, but only the last script wins (has it's menu displayed).
So it seems as if I can only use one scripts to handle the menu for all scripts with functionality (and call them from the menu-script).
Is this correct?


Best regards

Boris

Pages: [1]