Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jacob Vos

Pages: [1] 2 3 4
1
Suggestions and Requests / Re: "Method and Style" BPMN Functionality
« on: October 17, 2014, 03:51:54 pm »
About the pool / business process issue. Did you try the following? In EA, the properties of a pool contains 'processRef'. With 'processRef' you can refer to a business process (= Business Process element).

Following the BPMN specification (par. 9.3) by setting 'processRef' you indicate that the pool 'references' or 'contains' a process. Now I don't know what is meant with 'references', but at least 'contains' is something different than 'is'. So it's correct that in EA Pool and Business Process element aren't both a representation of the same thing.

To summarize. There is the process 'Handle Order'. You define a business process (element) with that name and a pool with that name. You link both by setting the pool's 'processRef'.

About your second issue (it would be better to have a separate thread for it): I don't recognize this. I can define global tasks and reuse them, including incoming and outgoing sequence flows. I use version 11 build 1111.

2
In Sparx EA, elements can get a status, a version, etcetera. Alas this is not possible for relations (connectors) between them.

I would like to have this, for example to indicate (in an ArchiMate model) that a flow relation doesn't exist anymore.

3
General Board / Re: BPMN with Sparx: Is there an in-depth text boo
« on: October 06, 2014, 10:11:49 pm »
As far as I know: no.

5
General Board / Re: Risk Modelling
« on: October 16, 2014, 05:13:57 pm »
You can model Risks also by applying the concept 'Assessment' from the ArchiMate language (the Motivation Extension).

6
General Board / Re: BPMN: Data associations at two levels?
« on: October 06, 2014, 10:11:02 pm »
You have to create the data association at both levels.


7
General Board / Re: Errors after migrating to EA11
« on: July 01, 2014, 03:46:39 pm »
On May 14th I wrote: "The other [support issue] was about the impossibility to add documents to the model. (I use an eap file.) "

I now got feedback from Sparx on this issue. It turned out that adding documents inside your model is NOT meant to be in the Desktop nor in the Professional edition. The functionality that looks like you can do this in those versions, will be removed from those versions.

So for having documents inside your model you need version Corporate or higher.

- Jacob

8
General Board / Re: Errors after migrating to EA11
« on: May 14, 2014, 02:59:19 pm »
I think that for such issues you better log a support request with Sparx. Last days I logged two issues with them that maybe are related. One had to do with the impossibility to draw BPMN message flows between pools that are placed wihtin a certain node in the Project Browser. The other was about the impossibility to add documents to the model. (I use an eap file.)

9
General Board / Re: BPMN Message attributes/paramaetesr
« on: May 08, 2014, 01:03:59 am »
Hi Gary,

I think you go very detailed if you want to formally specify the attributes in BPMN (so in another format than text).

Maybe it's enough for you when the service is described at one place in your BPMN model. I was thinking about the following.

Let's say the 'Common Client' service comprises three steps: message start event, service task and message end event. Calling the service means two message flows with the process from which you want to use the service: one to the message start event (= request) and one from the message end event (= response).

To each message flow, a message can be linked. See the tag 'messageRef'. So you can have a 'request message' and a 'response message'. You could model them and describe the attributes there.

However: how to define this 'construct' of three steps only once? In fact it is a process, so you could model it as a (global) process, to be reused. However this would require that every time you want to invoke the service you have to define a Call Activity in the process from which you want to do the invocation. So still much modelling effort.

So I was thinking to model a reusable process called 'Use Common Client Service'. This would comprise an activity to call the service (not within a pool) and also the three steps mentioned above (in a pool) and the message flows as described above.

Then in the processes where you want to use the service, you define a Call Activity (tag 'isACalledActivity' (sic!) = true) that you let refer to the reusable process (tag 'calledActivityRef' = set to '<<Business Process>>Use Common Client Service').

Those are my thoughts, but I am open to alternatives.

- Jacob

10
General Board / Re: Search Published HTML Report
« on: October 25, 2013, 04:04:14 am »
I agree with Graham.

11
General Board / Re: RTF output Diagram connector
« on: February 19, 2014, 05:22:51 pm »
I was able to insert information about connectors displayed on a diagram that was in another package than the elements displayed on it.

The sections I have selected:
- Package
-- Element
--- Connector
---- Source
----- Element
---- Target
----- Element
-- Diagram
--- Element
--- Connector

I am still not getting the info and lay-out I want to get, but hopefully it helps you.

12
General Board / Re: Exported diagram has empty space
« on: January 14, 2014, 09:09:33 pm »
I have a diagram that only displays ArchiMate application components, but it has still the 'white space problem'.

- I didn't place any connectors on it, or removed it.
- For all certainty I pasted the components on a brand new diagram, but still the same problem.

So if connectors are the cause, they are not the only cause.

13
General Board / Re: Exported diagram has empty space
« on: January 10, 2014, 12:04:56 am »
I also have the same problem - with BPMN diagrams, but also with other kinds of diagrams.

14
General Board / Re: Using Crow's Feet Connectors for database mode
« on: January 20, 2014, 11:04:51 pm »
Don't the connector line ends on the diagram for which you changed the Connector Notation automatically change into crow's feet style? Because that's the way how it should work. So not by first changing a parameter and then - per connector - change the style.

15
General Board / Re: Insert template fragment into document templat
« on: January 15, 2014, 01:56:30 am »
I tried different locations and see it worked within 'package' but outside 'diagram' and 'element'.

Thank you for your feedback!

Pages: [1] 2 3 4