Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Zanac

Pages: [1]
1
Hi

Most likely, the objects that are presented in the window come from a SQL ... just missing an "ORDER BY T_Object.Name ASC"

 :D ;D :P

Going again to Feature Request
https://www.sparxsystems.com.au/support/forms/feature_request.html

2
Same problem here...  :'(

3
Hi Arshad,

Thank you for your patience ... my project is stopped, waiting for me to solve this problem.

I followed yours steps, but it seems to me that the result produced was another. I ask you to verify my thinking.

"Copy the above query an paste it in SQL scratch pad , Give a new Search name by selecting the high lightened option like below and save it."
https://imgsafe.org/image/9931f3cf72

When I click the indicated button, I'm actually copying the "Simple" Search from the "Common Searches" Folder .... and I'm not creating a search from the inserted SQL.
https://imgsafe.org/image/9933678c62

Actually, as you indicated, the TestSearch will appear in the "Import Search from EA" window.
https://imgsafe.org/image/9933fc22d4

But, the loaded search is not the typed SQL ... it's actually the "Simple" Search
https://imgsafe.org/image/9934a9f39f

Look to the Element... Alias... Name... Notes... its same "Simple" Search (copied to TestSearch when clicked the copy button).
https://imgsafe.org/image/99353b884a

https://imgsafe.org/image/9935e8f87f

==========================

Back to your steps...

"Copy the above query an paste it in SQL scratch pad , Give a new Search name (...)" To creat a search from the inserted SQL, I should click the "Save as New Search" button.
https://imgsafe.org/image/99368d692e

Then the new search was created ... "TestSearch2"
https://imgsafe.org/image/99370c580e

But the new search "TestSearch2" does not appear in the "Import Search from EA" window.
https://imgsafe.org/image/9937de4600

==========================

Is this my analysis correct?

Does the EA only allow the user to perform "Elements Filter" from search builted through the "Query Builder"???

Best regards,
Zanac

4
Hi Arshad,

Thank you for the quick response...

But, I had tried this too...

I saved my search, and imported... but any search does appear in the "Import Search from EA" window list.

In my "Import Search from EA" window... below the label "Select a search to import"... I have only the "Search" header/sorter.

https://i.imgsafe.org/93/932d44440c.jpeg

Did you can show the "Import Search from EA" window with searchs?

What do I need to my searchs to appear in the "Import Search from EA" window list?

Im using a single SQL:
SELECT t_object.Object_ID
FROM t_object
WHERE t_object.Object_ID = 1117

Best regards,
Zanac

5
Hi,

First, I created a search using the "Search Tool" and exported the search to an XML file on the local drive.

Then I created a Document Template ... Document Options ... Element Filters ... Import Search ... From File ... then I choose the XML file created ... the "Import Search" window appears...

When I click the OK button, the EA crash.

I tried to perform this operation on different machines... always using version 13.

Maybe there needs a template for SQL, like the Except Query to Package... (SELECT t_package.Package_ID AS ExcludePackage...)

Has anyone been able to import a search into "Element Filters" in "Document Options"?
Or can you indicate any material that shows how to do this action correctly???

Best regards,
Zanac

Pages: [1]