Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - timoc

Pages: 1 2 [3] 4 5 ... 11
31
I tested this on EA version 15.1

Maybe I've used features that were not yet available in v15.

I'll check and report back.

Geert

I've been looking at this too - I can only use it reliably with one model open. If i have multiple EA instances open it seems to choose the one i opened first, not the one i opened last.


32
Bugs and Issues / Re: Linux - problem with XML export
« on: February 28, 2020, 09:54:19 pm »
I use crossover at https://www.codeweavers.com/. If you are wiling to invest in a tool like EA and use Linux, crossover is well worth it. You can try a demo before investing. It is a managed wine environment, once set up allows you to export/backup your EA between distros, and across versions.

You may also have luck under Steam for Linux, which uses crossover technology under the hood, but i have not tried it.

33
Automation Interface, Add-Ins and Tools / Re: Custom Table Script context
« on: February 28, 2020, 03:20:45 am »
I'm interested in this as well. The Sparx Custom Table section found on
https://sparxsystems.com/enterprise_architect_user_guide/15.0/model_domains/custom_table_artifact.html
doesn't have anything meaningful written about scripts.

I don't know what scripts to write. Is it the same jscript ones I write in the Scripting window? Will it recognize commands like Repository.SQLQuery()? Am I supposed to shoot for the script to output data in .xml format? Array format?

The help page is entirely unclear about this and basically only mentions something to the effect of, "You can invoke a behavior script."

I looked at it when it came out, but was dissapointed - it is a kind of cludgy. Think of it as a way of embedding table based information into an artifact for documentation. You are kind of limited to using the table manipulation tooling to make the table. You cannot import to or export from (except clipboard paste), so it is not even good for an embedded CSV source.

The underlying implementation is like an XHTML <table/> stored in a single SQL record - being a not invented here, the XML is not the global HTML standard for table and table formating, but their own XML markup (defined in the doc link).

You might be able to use some kind of SQLXML extensions to query it's contents, but i am not sure what for, because matinainting it as a source for anything looks like hard work.


34
Bugs and Issues / Re: Flowcharts broken?
« on: February 27, 2020, 11:04:26 pm »
Assuming a recent version of EA, try:

Start/Preferences/Preferences/Links and uncheck "Strict Connector Syntax." Welcome to the Standing Room Only club of people who have run afoul of the compliance policy.
:P of course.

35
Bugs and Issues / Flowcharts broken?
« on: February 25, 2020, 11:08:32 pm »
When i try and connect any items, as outlined below here:
https://sparxsystems.com.au/enterprise_architect_user_guide/15.1/model_domains/flow_chart.html

I get the ironic error message "the requested connection is not uml compliant"

Is this a bug, or am i missing a feature toggle?

36
Bugs and Issues / Spell checker failure - example in Specification manager.
« on: February 22, 2020, 12:28:04 am »
I am seeing the spellchecker underline feature fail in the specification manager. If i create an element with the title:
Quote
"Element(this +that thing) is #four"

I see the spellchecker underlining:
Quote
Element(this +that thing) is #four

Is there an option somewhere to fix this, or is it an issue?

37
Automation Interface, Add-Ins and Tools / Re: DBMS versus SVN Versioning
« on: February 21, 2020, 07:40:33 pm »
With a DBMS backend you have the option to do both. You can use your free pro cloud server (from v4.x?) to setup a Reusable Asset Service (RAS) server with your DBMS as its backend. You can setup multiple databases to manage different assets.
https://sparxsystems.com/enterprise_architect_user_guide/15.1/model_repository/reuseable_asset_service.html

The RAS works as a kind of version control, one that you can use in a baseline type process and for diffing against your DBMS live model. Or at least that is my understanding. I'm starting to use it, so maybe other RAS users can comment in more detail.


38
Automation Interface, Add-Ins and Tools / Re: is !INC Local
« on: February 18, 2020, 02:32:36 am »
I have been thinking about this

Is "!INC Local" the on
:-\ Seems you are missing a part...

Geert
Yep.
Removed it as it was a stupid wood for the trees post. I had this idea that "!INC Local Scripts." meant "!INC" "Local" "Scripts."

39
Automation Interface, Add-Ins and Tools / is !INC Local
« on: February 18, 2020, 01:50:25 am »
I have been thinking about this

Is "!INC Local" the on

40
General Board / Re: Linking to related models in Archimate
« on: February 17, 2020, 07:51:47 pm »
I cannot see there is linked information behind an element unless i select the element, and it shows the 'eye'. This will not work for me, which is why we have been thinking about hyperlinks.

I'm looking at an ArchiMate business viewpoint right now in EA 13 where it's displayed and working.
This is my fail, i did not check further. The link symbol only appears when the shape used is the one with the icon in the top right. Select the linked item, and pick the alternate view button from the quick-linker, and the link symbol disappears.

I will report the issue, and adjust my diagrams accordingly.

Experimenting further, the link symbol does not work with general diagram shapes either.

41
General Board / Re: Linking to related models in Archimate
« on: February 15, 2020, 12:56:52 am »
use composite diagrams?

Geert

Composite does not work they way i need it to. I know i can select/create a composite diagram to drill down to (in 15.1). My problem is that this relationship is not visible in the Archimate diagram. The symbol that shows that there is a linked diagram does not appear. When discussions on Archimate shapes have come up (e.g. notes, features etc), the usual line is 'not in the spec'.

I cannot see there is linked information behind an element unless i select the element, and it shows the 'eye'. This will not work for me, which is why we have been thinking about hyperlinks.

Any other ideas?

42
General Board / Linking to related models in Archimate
« on: February 14, 2020, 05:14:19 pm »
I want to have a kind of drill down in my Archimate models, so that i can link to related models. At the moment i have to use an explicit hyperlink artifact beside my abstracted element.

Is there a better way?

43
General Board / libmicrohttpd.dll?
« on: February 01, 2020, 09:58:21 pm »
Hi,

I see there is now a webserver component distributed with EA.
Is it possible to use this from the scripting engine?


44
General Board / Setting color schemes at startup, or triggered?
« on: January 07, 2020, 08:41:53 pm »

Is it possible to set a color scheme from a command line shortcut, or trigger it somehow? I would like to be able to differentiate, on sight by color scheme, between EA 15 and EA15.1 Beta, or an EA working on Model A or Model B.






45
Is it possible to use this new feature:
https://sparxsystems.com/enterprise_architect_user_guide/15.1/model_publishing/projecttransfer_nativexml.html

With baselines or similar for file based project branches?

Pages: 1 2 [3] 4 5 ... 11