Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - qwerty

Pages: 1 ... 16 17 [18] 19
256
Automation Interface, Add-Ins and Tools / text instead of shape
« on: January 20, 2014, 12:34:34 am »
One of the MDGs uses a text <name> instead of a shape <name>. I could not find any difference in the effect of both. Does anyone know more about it. The help does not mention it at all.

q.

257
Automation Interface, Add-Ins and Tools / SetPen in shape script
« on: January 20, 2014, 08:02:22 pm »
To whom it may concern: Using
Code: [Select]
SetPen(get...Color(),<size>) has strange effects if there are bends in an applied connector shape. Using
Code: [Select]
SetPenColor(get...Color());
SetPenWidth(<size>);
however works as expected.

q.

258
Automation Interface, Add-Ins and Tools / #istagged# in shape script
« on: January 20, 2014, 12:08:29 am »
Does anybody know what this hash tag returns?

q.

259
Automation Interface, Add-Ins and Tools / #weight#  in shape script
« on: January 18, 2014, 06:49:59 am »
Does anyone know what this hash-tag returns (for a connector). I can't seem to find any weight property.

q.

260
When I try to assign a value (off or standard as suggested by the help) the compiler claims
Quote
Error: Invalid value for orientation. Acceptable values are: "nw", "n", "ne", "e", "se", "s", "sw", "w", "nw",  and "center"'off

Has anybody at Sparx tested this shape script in any way? I do not expect an answer to that question >:(

q.

261
Can someone confirm that the following shape produces non-sense:

Code: [Select]
shape main {
      MoveTo(50,50);
      ArcTo(0,0,100,100,100,50,0,0);
}

Even worse:
Code: [Select]
shape main {
      MoveTo(50,50);
      ArcTo(0,0,100,100,100,50,100,0);
}

q.

262
Someone getting sick of this? Well, I am...

I tried to use sub-shapes with 2 parameters where layoutType="border". It seems that only "N" and "CENTER" produce results, both being the same. Using "S" shows some strange result in the preview, but none at all on the real diagram.

q.

263
Automation Interface, Add-Ins and Tools / #classifier# in shape script
« on: January 15, 2014, 11:47:01 pm »
Has anyone an idea what this and the associated dot-notated hash tags will print? I have used Advanced/Parent and a Generalization. None seems to influence the tag. Bug?

q.

264
How do I do that? Println ("""") causes a compiler error. Println("\"") will print both the escaping backslash and the quote. Is there a #QT# or something crude alike?

q.

265
Automation Interface, Add-Ins and Tools / Creating a custom toolbox icon
« on: October 04, 2013, 07:43:30 am »
I was asked by someone how to create a toolbox icon in a MDG. I thought having done that in the past but could not remember. So I started trying and reading the help. Neither worked :-(

The EA help states
Quote
To set the icon for a toolbox item, locate the item in the Toolbox Items list and click within the Toolbox Icon column. Click on the ellipsis () within this column.  The Select a Toolbox Icon dialog displays. Locate the image file and click the Open button
But there is no Toolbox Icon column in the Toolbox Items list. They are plainly displayed as simple attributes - which don't have something like an icon.

Any help available?

q.

266
Automation Interface, Add-Ins and Tools / Wow!
« on: June 13, 2013, 04:26:14 am »
Instead of "Error - Missing" I now get "Error - Missing (0x80040154)"!

Which incredible step forward! An error code!

Would someone from Sparx be so kind to explain what this error code means? I mean, I'm no wizard nor a clairvoyant.

Honestly, I'm quite pissed off by the level of debug info we get from EA when it comes to automation or MDG deveolpment >:( >:( >:(

q.

267
Diagram.SelectedObjects

q.

268
I have just published a new e-book about EA's API at http://leanpub.com/ScriptingEA

It starts with a help yourself section so beginners are introduced into the basics. Quite some "bits and pieces" summarize inside information which is not obvious. A final cross reference from GUI to API (not yet complete) ends it up.

Although this is "under construction" I think the current state is worth while to be published. I'm planing to complete it over the next one or two months. Next chapters to be completed: final cross reference; object creation/manipulation.

Hope you enjoy it.

q.

269
I guess there are not many using just their own profile with everything else turned off. However, here's my observation: every now and then EA decides to enable the Extended profile. This can be seen when hitting the space key on a diagram. On top of Other/MyProfile the Extended menu is offered. Also the QL shows entries which are not from my profile but likely taken from the Extended profile.

I have no clue when this happens. For a time it did not happen but today it is turned on each time I start EA. After dis-/enabling my profile the situation is cleared but only after the next EA restart when the Extended profile is activated once again.

Before sending a bug report I'd like to know if anyone else experienced this behavior.

q.

270
It seems that when you create a stereotyped package from a profile and EA fires OnPostNewPackage it does not seem to supply the stereotype. Can anyone confirm that (9.3)?

q.

[edit:] I tried also to check for other profile data. The URI which appears in t_xref is created AFTERWARDS. At least I can not find it during OnPostNewPackage. A Tagged Value also seems to be created AFTERWARDS. Why, why, why? Should the method be called OnSomeWhereInbetweenCreatingPackage?

Pages: 1 ... 16 17 [18] 19