Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - jumbie

Pages: 1 2 [3]
31
General Board / reference from text
« on: March 11, 2006, 02:02:20 am »
Hi all,

Is it possible to make a reference from text (Note, Scenario...) to element name in model, so that after changing the element name in model the name in text will be changed too?

If not, is it in plan of any new version of EA?

Thanks for answer ,

jumbie

32
Bugs and Issues / Problem with exported and back imported RTF docs
« on: March 05, 2009, 09:34:35 pm »
After exporting to file and back importing from this file RTF linked document does not work correctly - links are not active. :-/  The same problem with Cut and Paste of link.

33
beginner, thanks, but as I said, the other COM objects like “ADO.Connection” are working well... :)

34
Thanks for answer, but without solution.

The script in VBS file on my machine

Set rep = CreateObject("EA.Repository")
rep.Openfile("C:\eatemp\test.eap")
Msgbox rep.models.count
rep.ShowWindow 1
msgbox "Opened"


is working good.

I have my intranet local web server installed on the same machine as EA. If the problem is in license details, how can I solve this problem and create object in PHP?
Is it possible?
Thanks for answers!

35
I want to create object EA.Repository from PHP with “new COM” syntax:
$rep = new COM("EA.Repository");
No success = no answer from browser.
The same problem with command:
com_load_typelib("EA.Repository");
I have local web server on the same machine as EA. The other COM objects like “ADO.Connection” are working well.
Is it possible to connect EA from PHP and how? Thanks for answers!

36
...the row:

Set lMyUctrl = objTab

in your example is raising the same error Type mismatch.
The problem is only delayed  :)...

Now I work with object lMyUctrl without downcast (i.e. as Object), I call its methods from interface UserControl1 and it is working (!), but of course without intellisense in VB 6.0 => I must write code by this "untyped unpleasant" way.

Changing interface to UserControl1 is not working and I dont know why...  







37
Automation Interface, Add-Ins and Tools / help with custom view - AddTab
« on: February 25, 2007, 05:00:11 am »
I have this problem with custom view created by my own user control, please help me:

In VB 6.0, this code does not work:

Dim lMyUctrl As Project1.UserControl1

Set lMyUctrl = Repository.AddTab("Hello", "Project1.UserControl1")

The tab is created in EA with name “Hello” correctly, but setting the returned object from AddTab into lMyUctrl is raising run-time error “Type mismatch”.

Can You help me with a little advice?

Thanks.

38
Automation Interface, Add-Ins and Tools / Re: add in - hello world
« on: April 02, 2006, 04:42:06 am »
...oh, oh, … the problem is solved and I need new strong glasses! The position of Add In key in registry is not

HKEY_CURRENT_USER\Software\Sparx Systems\EA400\EA\AddIns

(it exists in registry and I used it…)

but

HKEY_CURRENT_USER\Software\Sparx Systems\EAAddins

(it must be created as a new key what is written in Help).

Now my “hello world” is saying hello correctly…

Thanks


39
Automation Interface, Add-Ins and Tools / add in - hello world
« on: April 02, 2006, 02:41:32 am »
Hi all,

I use VB 6.0 and I am newbie in creating Add-Ins in EA. The technique in EA Help is not enough for me – my code and settings are not correct, and I don’t know, where the mistake is.  

Is it possible for anybody to send me description of any small application like “add in - hello world!”  with description how to connect it, what must be set, how to debug it and how to finish it to installations? After it, I may be able to find out my mistakes .  

Maybe some detailed instructions “add-in in EA for dummies” exist and somebody can send me only the link.  

Thanks for help!

Pages: 1 2 [3]