Author Topic: IIS + SPARX CLOUD, Installation problem  (Read 2523 times)

haltekx

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
IIS + SPARX CLOUD, Installation problem
« on: October 26, 2016, 03:57:21 am »
Welcome,

I am trying to setup IIS + Cloud.

After 3 days of help from SPARX (Thank you for tips) i figured out (by myself..) that instruction have some bugs
(like there is nothing said about which user should start sparx cloud service - only in troubleshooting mention...).
 >:(

Anyway..

Now I have working SPARX Cloud, connected to database, and Architect (trial) on the same server. They are working on ports 804, http - nprbl.

I configure IIS with module isapi, after it with module http (deleting isapi configuration) - but it still do not working... in both cases:
Architect answer: "The webservice is currently unavailable. Http Status Code: 404"
But on IE i can see on localhost IIS default webpage..
 :o

Look like IIS cannot go throuh HTTP/ISAPI module to SPARX Cloud...

Can any one say some help tips? I read that manual ten times so far..(and obviously www sparx manual pages)

Any one?

Greetings,
Haltekx

Of course firewall off
Of course Windows 2012R2 Standard + IIS8.5



Eve

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6963
  • Karma: +71/-10
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #1 on: October 26, 2016, 08:15:32 am »
If you're getting a 404 error from IIS, look at the request restrictions dialog described in the help.

Quote
Note: The 'Mappings' tab should be left with the default settings, that is 'Invoke handler only if request is mapped to' is not ticked.

That checkbox being checked will cause IIS to report a 404 error if you don't actually have a file sscloudlink.sseap in your inetpub directory. The only other reason I can think to get a 404 is not having a mapping configured at all.

Finally, just in case you have misinterpreted the IIS integration as a requirement instead of an option...

Quote
For most users, the built-in web server provided with the Cloud Server provides all the functionality they need. It is also the easiest method to set up and use.

However, the Cloud Server also provides the option of integrating with Internet Information Services (IIS). This is only recommended for users for whom the built-in authentication methods are insufficient, and who want to use Windows Active Directory or certificate-based authentication.
« Last Edit: October 26, 2016, 08:17:39 am by Simon M »
Eve

support@sparxsystems.com

haltekx

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #2 on: October 27, 2016, 12:04:02 am »
Hi,

I unchecked (default was checked!!) option:  'Invoke handler only if request is mapped to' and checked with Mappings tab to "script" /"execute"
(all 4 combinations)

Also i have:
sparxcloudlink.sseap:
port=804

SSCloudServices.config:
SERVER_PORT=803

iis (http):
port=804

I check/try to use IIS on port 803 -- IIS cannot start. (sparx listning on 803)

Any help?



ps.
Client require AD+HTPPS. On SPARX Web Server - it is working (on http)





haltekx

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #3 on: October 27, 2016, 12:55:37 am »
It works with settings:

IIS - port 804.
sparxcloudlin.sseap - port 803
SSCloudService.config - port 803

1.
 'Invoke handler only if request is mapped to'  - unchecked /default was checked/
tab mappings: script. /default/

2.
I change to:
tab mappings: execute. /default/

working

3.
After option checked ->

 'Invoke handler only if request is mapped to' 

IIS connection to SPARX not working

I REALLY advise to change manuall, cause:
" Note: The 'Mappings' tab should be left with the default settings, that is 'Invoke handler only if request is mapped to' is not ticked."

is not acctullly true.

Also there is not mension about user who should start SPARX service (it is mension in troubleshooting only)


OK.


Moving on -> now trying AD, HTTPS.


Thanks for clue - It Helped me a lot!!!

 ;D




haltekx

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #4 on: October 27, 2016, 01:42:42 am »
Hmm - know every time i am trying to connect i have got:
"Database connection Error. Reopening connection to database"
...

was working - now is not working..
grrrrr

Any Idea?
-- Architect is connecting to database directly without problem..

haltekx

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #5 on: October 27, 2016, 04:12:17 am »
After change to HTTP MODULE (didnot helped)
i change to ISAPI MODULE again and...

i have only HTTP STATUS 500 ..

 :-X

Eve

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6963
  • Karma: +71/-10
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #6 on: October 27, 2016, 11:54:07 am »
"Database connection Error. Reopening connection to database"

At a guess, your database connection was set-up to use NT integrated authentication. This is probably why you changed the account for the service (and had the issue you did) Then if you change the account the service is run from back to the services account, the NT authentication will fail.

500 just means unknown server error, so it's about the least useful code IIS could report. (And the configuration difficulty of setting up IIS integration is why it's not generally recommended)
Eve

support@sparxsystems.com

haltekx

  • EA Novice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #7 on: October 28, 2016, 12:36:37 am »
That explains a lot.

But... i still have the service started with the same NT user from wchich I am trying to connect to Cloud (on localhost)

It should work?


And qestion - if start with NT\user, is other users in AD can normaly login to cloud?
The "work" (diagrams etc.) will be seen as they jobs? (not as job NT\user)


Thanks for explain, and sorry that i do not know any thing about EArchitect (true).
My job is to install it for client who used to use it only in EArchitect version, it
do not make me an expert  ;D

Thank You for helping me out, with that problem.





Eve

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6963
  • Karma: +71/-10
    • View Profile
Re: IIS + SPARX CLOUD, Installation problem
« Reply #8 on: October 28, 2016, 08:36:20 am »
Everything executed by the cloud service will be executed (and recorded anywhere it's recorded) as being done by the account that runs the service. For EA, the default author of anything created in the model will be the windows login of the user making the change. If security is enabled, it will be the firstname/lastname of that user as specified in the model.

The only impact that the domain authentication provided by IIS will provide is preventing people accessing the model (through IIS) who can't provide valid domain credentials. On a private, internal network where anyone on that network is trusted, it doesn't provide any benefit.
Eve

support@sparxsystems.com