Author Topic: Unrecognized database format  (Read 2447 times)

jplusip

  • EA User
  • **
  • Posts: 69
  • Karma: +0/-0
    • View Profile
Unrecognized database format
« on: May 08, 2015, 05:48:48 am »
At the moment, whenever I try to open my project (that was working fine yesterday), I get the error: Unrecognized database format and then it shows the filename.

I actually ran into this issue on Monday as well, and as a result went on to a different project file (I didn't lose much work then) that I have on my Desktop. But now I'm getting the error on my recent project (which I've invested a decent amount of work in) but not in the original file that was giving me issues.  :o

How do I fix this? (And yes, the file is a .eap).
« Last Edit: May 08, 2015, 05:49:18 am by jplusip »

qwerty

  • EA Guru
  • *****
  • Posts: 10585
  • Karma: +232/-192
  • I'm no guru at all
    • View Profile
Re: Unrecognized database format
« Reply #1 on: May 08, 2015, 06:22:21 am »
You need to use a backup since something crashed you file. Try opening it with some native MSAccess tool (eventually rename it to .mdb temporarily). But most likely you need to go the first way.

q.

Sunshine

  • EA User
  • **
  • Posts: 855
  • Karma: +66/-4
  • Its the results that count
    • View Profile
Re: Unrecognized database format
« Reply #2 on: May 08, 2015, 08:15:23 am »
Suggest following steps
a) make copy if you don't have backup
b) Run the EAP repair tool. In V12 the menu is Project>Data Management>Manage .EAP File > Repair .EAP File

c) if that works then do a project integrity check hot key Shift+F9

Should be okay after that.

If not resort to back up file

If no backup file then bad luck  :(
Happy to help
:)

jplusip

  • EA User
  • **
  • Posts: 69
  • Karma: +0/-0
    • View Profile
Re: Unrecognized database format
« Reply #3 on: May 09, 2015, 01:47:50 am »
Using the Repair EAP file worked. Thank you very much!!

It's strange though, I only have three or four packages in the project and maybe 20 blocks total. I'm just doing some "sandbox" work away from the main model so I don't have so much clutter to deal with, so I'm unsure what could be causing this issue. I'll run the integrity check though and see what that turns up.

Thanks again for the help!
« Last Edit: May 09, 2015, 01:48:17 am by jplusip »

Sunshine

  • EA User
  • **
  • Posts: 855
  • Karma: +66/-4
  • Its the results that count
    • View Profile
Re: Unrecognized database format
« Reply #4 on: May 10, 2015, 09:39:59 am »
Glad to hear it worked ok.
The cause could be something to do with where your storage system is located for the eap file. For instance I've known in the past people have problems running eap files on a network storage or shared file locations. Usually some kind of network issue combined with how MS Access database works. If problems persist consider alternative storage location.
I usually work with EAP files on my c: drive then copy/ backup. Found Skydrive good for doing this automatically.  
Happy to help
:)