Author Topic: Linked elements not shown in Report  (Read 1457 times)

michielper

  • EA User
  • **
  • Posts: 105
  • Karma: +1/-0
    • View Profile
Linked elements not shown in Report
« on: July 19, 2016, 09:17:28 pm »
When I open an element (im using Archimate), it shows the other elements with which it is linked. However, in the Document generator, this information cannot be included!! Why not??

Glassboy

  • EA Practitioner
  • ***
  • Posts: 1241
  • Karma: +93/-75
    • View Profile
Re: Linked elements not shown in Report
« Reply #1 on: July 20, 2016, 08:08:23 am »
When I open an element (im using Archimate), it shows the other elements with which it is linked. However, in the Document generator, this information cannot be included!! Why not??

It can.  Are you talking about one of the canned templates specifically?

michielper

  • EA User
  • **
  • Posts: 105
  • Karma: +1/-0
    • View Profile
Re: Linked elements not shown in Report
« Reply #2 on: July 21, 2016, 05:45:46 pm »
Ok, let me explain.
I want a report that lists all the elements matching my search query (e.g. based on a name match) and then with each element, I also want to have the names of the elements to which it is connected, preferably also the type and direction of the connector involved. I have not yet found a way to do this in a report while all this information is visible when you open the element properties.

Thanks for any help!

Glassboy

  • EA Practitioner
  • ***
  • Posts: 1241
  • Karma: +93/-75
    • View Profile
Re: Linked elements not shown in Report
« Reply #3 on: July 22, 2016, 08:57:05 am »
So it sounds like the search part needs to be some kind of "fragment", I haven't played with these so i can't comment.  The linked elements is a standard part of the document template.