Author Topic: Searching for special characters in element name  (Read 1564 times)

mrblack12

  • EA User
  • **
  • Posts: 67
  • Karma: +0/-0
    • View Profile
Searching for special characters in element name
« on: January 23, 2017, 11:44:30 pm »
Hi,

I'm trying to construct a search query that searches for elements with a special character - like &,*,+,), etc. - in the name. I'm doing this using a wildcard search but the only character for which it doesn't work is the wilcard character itself: '*'. Using just an asterisk as search term results in the entire repository, duh!

I'm thinking there might be a way by using an escape character like a forward or backward slash but that doesn't seem to do the trick either. Any suggestions on this?

Thanx,
Rick

qwerty

  • EA Guru
  • *****
  • Posts: 10769
  • Karma: +241/-213
  • I'm no guru at all
    • View Profile
« Last Edit: February 01, 2017, 01:47:02 am by qwerty »

mrblack12

  • EA User
  • **
  • Posts: 67
  • Karma: +0/-0
    • View Profile
Re: Searching for special characters in element name
« Reply #2 on: February 01, 2017, 01:44:26 am »
Found it! Turns out you have to use the square brackets: so using
  • as search term will find all elements with an asterisk in them, instead of returning everything....

qwerty

  • EA Guru
  • *****
  • Posts: 10769
  • Karma: +241/-213
  • I'm no guru at all
    • View Profile
Re: Searching for special characters in element name
« Reply #3 on: February 01, 2017, 01:47:51 am »
Ooops. Just saw that YABB swallowed it. I updated the post :-[

q.