Author Topic: Stereotype for ActivityInitial buggy / Tagged Values "appliesto" as well  (Read 1849 times)

Shegit Brahm

  • EA User
  • **
  • Posts: 95
  • Karma: +1/-0
    • View Profile
Using EA 13.0

If I define a stereotype extending metaclass "ActivityInitial" with some attributes,
create myToolbox with it and export all as MDG,
import it to other eap.

In activity diagram I
- have to drag'n'drop from myToolbox to receive my customization (see http://sparxsystems.com/forums/smf/index.php/topic,38479.0.html for my observation)
- if I whyever delete any tagged value (originally attributes) from this node, I'm unable to restore them.
- neither sync nor "apply" again works.

Looking for a workaround I tried to define Tagged Values in UML1-style: using "UML Types"

But "AppliesTo" is fully ignored on ActivityInitial:

- e.g. for Decision works fine:
Type=RefGUID;
Metatype=Decision;
AppliesTo=Decision;

- for ActivitiyInitial doesn't show up:
Type=RefGUID;
Metatype=Decision;
AppliesTo=ActivityInitial;

"AppliesTo=Action" works as well, but not these nodes.

Any ideas how I can workaround this bug set a "model" Tagged Value that only applies to ActivityInitial?

qwerty

  • EA Guru
  • *****
  • Posts: 11388
  • Karma: +295/-262
  • I'm no guru at all
    • View Profile
If sync does not restore the TV you either made something wrong elsewhere or you need to report a bug. Try deleting a TV for BPMN2.0::Activity. The sync restores the deleted TV.

q.

Shegit Brahm

  • EA User
  • **
  • Posts: 95
  • Karma: +1/-0
    • View Profile
using "action" on a stereotype does also what you say / I expect. ActivityIntial not.

If I understand you correct, reporting a bug does never imply reporting it here inside "Bugs and Issues" but using http://sparxsystems.com/registered/reg_bug_report.html ? Well, that would explain something.


qwerty

  • EA Guru
  • *****
  • Posts: 11388
  • Karma: +295/-262
  • I'm no guru at all
    • View Profile
Exactly. This is just a user forum.

q.