Author Topic: Smart Placement Guides ... not working consistently?  (Read 639 times)

matthew.james

  • EA User
  • **
  • Posts: 155
  • Karma: +7/-3
  • Am I supposed to say something here ... ?
    • View Profile
Smart Placement Guides ... not working consistently?
« on: July 20, 2018, 10:11:09 am »
I'm assuming this setting under Alignment (Show smart placement guides) is the one that controls the 'magic blue lines' which indicate, while moving, when shapes are aligned.
I find this feature extremely useful, however I am confused as to why it is sometimes there and sometimes not ...

On a given diagram, with the same settings (specifically Show smart placement guides on, Smart Placement on) sometimes these lines appear and sometimes they don't.

With some pairs of elements I get nice blue guide lines even if the elements are quite a distant apart. With other pairs of elements I get nothing even if I bring them very close together.  In some cases it appears that the guide lines only work for elements of the same type, but in other cases even elements of the same type are ignored.  In some cases where two elements are 'guiding' together, those same elements won't 'guide' with others.

... ?

Guillaume

  • EA User
  • **
  • Posts: 796
  • Karma: +22/-0
    • View Profile
    • www.umlchannel.com
Re: Smart Placement Guides ... not working consistently?
« Reply #1 on: February 18, 2019, 11:34:21 pm »
To add to Matthew's comments, here are a few suggestions for improvement:
- Add spacing support (same as Powerpoint)
- When several elements are selected and if they're aligned, compare their common alignment(s) (e.g. top) with other elements.

I agree that it's very useful!
Guillaume

Blog: www.umlchannel.com | Free utilities addin: www.eautils.com


qwerty

  • EA Guru
  • *****
  • Posts: 10582
  • Karma: +232/-191
  • I'm no guru at all
    • View Profile
Re: Smart Placement Guides ... not working consistently?
« Reply #2 on: February 19, 2019, 02:54:53 am »
I suggested to look into Apple's Keynote some 15 years ago since they ever had those smart placements. It never made it to those developers.

q.

Takeshi K

  • EA User
  • **
  • Posts: 353
  • Karma: +9/-1
    • View Profile
Re: Smart Placement Guides ... not working consistently?
« Reply #3 on: February 19, 2019, 11:45:21 am »
Hi all,

Now targets of the smart placement must be the 'same level' - i.e. if an element is direct on the diagram and another is child element (on other element), there is no blue line between them.

In similar case, in an Activity diagram if an object is on a Partition (Lane) and another object is on different Partition, there is no blue line between them.

Maybe this is why you can not see the line in some cases.


I can't agree more about support for the spacing and selecting mutliple objects.

HTH,
--
t-kouno