Author Topic: EA Cloud Connection Problems with https over IIS  (Read 730 times)

PeterHeintz

  • EA User
  • **
  • Posts: 817
  • Karma: +49/-17
    • View Profile
EA Cloud Connection Problems with https over IIS
« on: August 06, 2018, 10:24:23 pm »
Following the user manual, I got WebEA working over IIS via https. However my cloud connection EA->IIS->Cloud Service is not working.
I get 404 The webservice is currently unavailable.

I tried to get it run with both the "http module" as well as "Isapi module".
My SSCloudServices still contains the old working non-IIS configuration with SERVER_PORT=803.  My sparxcloudlink.sseap point to port 803 as well.

I belief that the other “old” SSCloudServices ports are not relevant anymore, because of both EA and WebEA goes via https port 443 (as I configured) to IIS and IIS forwards to 803 in any case. Is that belief right?
If so why WebEA works but EA over cloud not?
Any idea?
Best regards,

Peter Heintz

Eve

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6841
  • Karma: +66/-7
    • View Profile
Re: EA Cloud Connection Problems with https over IIS
« Reply #1 on: August 07, 2018, 09:10:23 am »
Make sure you've followed the instructions at http://www.sparxsystems.com/enterprise_architect_user_guide/14.0/model_repository/cloud_server_iis.html

In particular, you need to define the request for sparxcloudlink.sseap to be the isapi/http module. Generally you want to enable it even if it doesn't correspond to a file or directory. You also need to configure the dll to forward to the cloud service itself, but if that was your problem you wouldn't be getting a 404.
Eve

support@sparxsystems.com

PeterHeintz

  • EA User
  • **
  • Posts: 817
  • Karma: +49/-17
    • View Profile
Re: EA Cloud Connection Problems with https over IIS
« Reply #2 on: August 07, 2018, 08:13:32 pm »
I tried to follow the IIS manual as good as I could!

In SSCloudServices.config the first port is defined as:
SERVER_PORT=803
Port Definition 1 and Port Definition 2 are still there but are not relevant any more according my belief, right?

sparxcloudlink.sseap looks like this (IIS and Cloud Service run on same machine)
[cloud]
server=localhost
port=803

What I have not done so far are the “Optional settings” (clear SSCloudServices.config)

I found one thing I had overseen for the http module:
“Note: The 'Mappings' tab should be left with the default settings; that is, 'Invoke handler only if request is mapped to' is not ticked.”
But fixing that did not help either.

Due to the fact that the behaviour is identical (screen to accept the certificate and then web service is not available message) for the http module and the ISAPI module, and the https certificates seem to work, there should be only the following section I did something wrong:

-Configuration Settings
-Application Pool Settings

And there is not so much one can do wrong.

Now I also did the “Optional settings” but disabling port 804 causes the WebEA to not work anymore (because it is configured to use port 804 by me).

Any idea what causes the cloud connection service to be not available?
Best regards,

Peter Heintz

Eve

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6841
  • Karma: +66/-7
    • View Profile
Re: EA Cloud Connection Problems with https over IIS
« Reply #3 on: August 13, 2018, 01:38:06 pm »
I'm by no means an expert at IIS, but I've configured the IIS integration a few times, mostly by trial and error before the current documentation existed. There's an amazing number of things that can go wrong with this. It's much easier to configure webserver configured into the cloud service itself.

You only need the http module or the isapi module. Both are ways that you can configure a mapping for a particular request to go to a dll.

If EA gets a 404 message from IIS, it's because a request for /sparxcloudlink.sseap returns 404. If you get this, it suggests that the handler mapping isn't correctly configured because it isn't even trying load the module. The error messages from misconfiguring the module itself should be different.

Once you've got that, you need to edit sparxcloudlink.sseap in the same directory as the module dll so that it can be read. There should be different errors returned if there are bad values in that file.
Eve

support@sparxsystems.com