Author Topic: AllocationActivityPartition doesn't allocate Activity/Action to Blocks (EA 13.5)  (Read 180 times)

Fábio Guarita

  • EA Novice
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Sorry for the older version but I believe the problem is still out since no one in the General Discussion Forum was able to observe the behavior expected below:

I want to use Partitions (swimlanes) to allocate activities/actions to blocks in an activity diagram as indicated in SysML 1.4 spec (ISO19514, pg 148, "Allocation Activity Partition" and described in pg151, link here).

I've tried the following:

1-Create activity diagram
2-Create activity act1
3-Create 'Partition' (from the toolbox)
4-Apply SysML 1.4::AllocateActivityPartition stereotype
5-apply Instance classifier block : block1
6-Move activity act1 within the partition/lane

Expected result:
-Allocate relationship created and visible on relationship matrix with the proper selections

Result obtained:
-No relationship visible in any view or matrix (even using start > search > search in model)

Obs.: I have also tried to use the <<allocate>> stereotype in step 4 and got the same result.
Obs.2: I have also tried with actions (atomic and callBehavior from other activities) and no "allocate" relationship is created among blocks and actions/activities.

PeterHeintz

  • EA User
  • **
  • Posts: 812
  • Karma: +47/-17
    • View Profile
Hi Fabio,
Here you might get some feedback or you might get not. To rise a real bug report you should go to Sparx homepage under „Support/Contact Us“.
Best regards,

Peter Heintz

qwerty

  • EA Guru
  • *****
  • Posts: 10505
  • Karma: +231/-190
  • I'm no guru at all
    • View Profile
Actually you find it down below this page in the Support section.

q.