Author Topic: MDG Technology "Missing"  (Read 1053 times)

Steve Wartik

  • EA User
  • **
  • Posts: 38
  • Karma: +0/-0
  • Why aren't I outside?
    • View Profile
MDG Technology "Missing"
« on: August 08, 2012, 03:05:53 am »
What does it mean when the status of an MDG Technology is "Error - Missing"? That's what the Manage Add-Ins window (menu item Extensions>Manage Add-Ins) is showing.

I've verified that the requisite file exists after invoking Tools>MDG Technology Import, so that's not the issue. Any ideas what might cause Enterprise Architect to display this status?

g.makulik

  • EA User
  • **
  • Posts: 355
  • Karma: +0/-0
    • View Profile
Re: MDG Technology "Missing"
« Reply #1 on: August 08, 2012, 05:11:03 am »
For my experience this indicates some error when loading the dll for the asociated AddIn. Probably some exception within the EA_Connect() or EA_OnPostInitialized() event handler implementation, or even earlier errors in construction of the EA AddIn main class.
Unfortunately this is one of the hard parts to catch when you're debugging EA AddIns, you need to attach debugging using EA.exe as external program for startup.

HTH
GŁnther
Using EA9.3, UML2.3, C++, linux, my brain, http://makulik.github.com/sttcl/

Steve Wartik

  • EA User
  • **
  • Posts: 38
  • Karma: +0/-0
  • Why aren't I outside?
    • View Profile
Re: MDG Technology "Missing"
« Reply #2 on: August 08, 2012, 06:13:59 am »
That may well be the problem -- I do have a dll that I haven't recompiled after upgrading to a 64-bit architecture. Thanks for the suggestion.