Author Topic: ProCloudServer with Linux wine  (Read 230 times)

HeikoK

  • EA Novice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
ProCloudServer with Linux wine
« on: October 22, 2019, 11:30:44 pm »
Hello, everybody,

I tried the Testprocloud server(https://www.sparxsystems.com/products/procloudserver/online-trial.html) with wine under Ubuntu 18.04 and got the following error:

microsoft OLEDB Persistence Provider [-2147467263] Requested Functionality is not implemented

Has anyone already managed to connect to the ProCloudServer under Linux? If so, which Wine Packages do I need?
(Duplicated Topic : https://sparxsystems.com/forums/smf/index.php?topic=10770.0 )

P.s. when will there be an EA native version for Linux ?


Arshad

  • EA User
  • **
  • Posts: 192
  • Karma: +11/-1
    • View Profile
Re: ProCloudServer with Linux wine
« Reply #1 on: October 23, 2019, 04:28:19 am »
This issue has already been discussed here many times.
Please find the fix below and for more details refer the original topic

https://www.sparxsystems.com/forums/smf/index.php/topic,30465.msg222335.html#msg222335




HTH

HeikoK

  • EA Novice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: ProCloudServer with Linux wine
« Reply #2 on: October 23, 2019, 06:24:19 pm »
thank you very much for the quick answer, I had already found this thread.
However, I could not do anything with the answer.

1) I was trying to execute EA from Wine -> What is the correct way to execute it ?
2) Missing IE6 installtion -> Is 'winetricks ie6' enough ?
3) Missing CrossOver installation -> This is commercial or? https://www.codeweavers.com/products/crossover-linux/
4) Missing executing EA from crossover to install missing components -> same as 3)

Eve

  • EA Administrator
  • EA Guru
  • *****
  • Posts: 6880
  • Karma: +67/-10
    • View Profile
Re: ProCloudServer with Linux wine
« Reply #3 on: October 28, 2019, 08:49:29 am »
I've never installed ie6 and don't run under crossover.

Code: [Select]
WINEPREFIX=~/$1 winetricks msxml3 msxml4 jet40
WINEPREFIX=~/$1 winetricks --force mdac28
WINEPREFIX=~/$1 wine ~/.cache/winetricks/jet40/Jet40SP8_9xNT.exe

The version of winetricks I have doesn't install jet40 properly, which is why it's manually run.

I run the mdac28 line every time wine is updated. I've heard conflicting things about whether I still need to.

 
Eve

support@sparxsystems.com