Author Topic: Upgrade Prolaborate from V3.1.x  (Read 23 times)

Prolaborate Support

  • Prolab Moderator
  • EA User
  • *
  • Posts: 143
  • Karma: +9/-0
    • View Profile
    • Visit us
Upgrade Prolaborate from V3.1.x
« on: February 12, 2020, 05:15:23 pm »
Please follow these steps to upgrade from V3.1.x:
Prerequisite: Pro Cloud Server license certificate should be available. Instructions to get it without interrupting current usage can be found in this link under section "Updating Licensed Pro Cloud Server Installations to version 4"
  • It is recommended to take a backup of Prolaborate folder and database
  • Visit this link and download Prolaborate and Pro Cloud Server (PCS) Installers using the credentials in your Pro Cloud Server document
  • Install PCS and restart Sparx Systems Professional Cloud service.
  • Add the License Certificate (.crt) to PCS
  • Enable Pro Features for the database managers configured in PCS, if not enabled already
  • Stop all Prolaborate services and processes (All services and processes starting with Prolaborate and websocketd process) from Task Manager
  • From the downloaded Prolaborate folder, run Setup.exe as administrator and complete the installation. Note there would be a brief wait time after you click on Next.
  • Check Prolaborate Versions in the Health Checks page. If there is a mismatch between current and latest versions, run the latest database schema on the Prolaborate database from the Release Notes page based on the database server used for Prolaborate.

Note:
  • For better performance, few validations have been introduced in the Charts widget of Dashboard. They need to be reconfigured if they are showing an error after upgrade
  • If you are using the other features of Pro Cloud Server not related to Prolaborate(say Integrations), please make changes as per this link and ensure everything is working fine
  • (Critical) If you are using the Prolaborate macro for Confluence, schedule your upgrade of Prolaborate and the macro together. The latest version of Prolaborate is compatible with only the latest version of the macro.
  • (Critical) After the upgrade of macro, do not change Default Repository. If you want to change, all the EA information that has been embedded using the macro needs to be reconfigured.
  • As the profiles in Create Elements are linked with the profiles in Modeling languages, the standalone profiles will not be available anymore.
« Last Edit: February 12, 2020, 05:21:02 pm by Prolaborate Support »
Happy to help!

SPARX PROLABORATE - SHARING & COLLABORATION SOFTWARE FOR ENTERPRISE ARCHITECT