Author Topic: SBPI registry key warnings in the PCS logs  (Read 58085 times)

Guillaume

  • EA User
  • **
  • Posts: 945
  • Karma: +29/-2
    • View Profile
    • www.umlchannel.com
SBPI registry key warnings in the PCS logs
« on: March 06, 2020, 09:21:40 pm »
Hi,

A client's Pro Cloud Server has been set up with Prolaborate with an active Token license.
I noticed in the PCS logs (C:\Program Files (x86)\Sparx Systems\Pro Cloud Server\Service\Logs)  the following message numerous times:

[WARNING]: Failed to open SBPI registry key during retrieval of SBPI Server Settings

We don't use the SBPI integration.
Is there something I can do to prevent these warnings?
Guillaume

Blog: www.umlchannel.com | Free utilities addin: www.eautils.com


coatie

  • EA User
  • **
  • Posts: 21
  • Karma: +0/-0
    • View Profile
Re: SBPI registry key warnings in the PCS logs
« Reply #1 on: March 31, 2020, 07:38:48 pm »
Hi Guillaume,

I had the same issue and solved it by adding the data manually to the registry, see below.
Somehow it was still giving the warning: "[WARNING]: Failed to read SBPI server port from registry, assuming default value of 8080"
After installing the latest Version 4.01.0044 this warning is now gone as well.

SBPI_Server_Settings.reg
Windows Registry Editor Version 5.00

[HKEY_USERS\.DEFAULT\Software\Sparx Systems\SQLBridge\SBPI]

[HKEY_USERS\.DEFAULT\Software\Sparx Systems\SQLBridge\SBPI\Server]
"Enabled"="false"
"LocalPort"=dword:00001f91
"Protocol"="http"
"Server"="localhost"
"Port"=dword:00001f92
"UseLegacy"="true"
"IngoreSSLErrors"="true"
"AttemptAutoDiscovery"="false"
"ClientProtocol"="http"
"ClientServer"="localhost"
"ClientPort"=hex(b):93,1f,00,00,00,00,00,00