Author Topic: Where have Diagram Tiles Gone?  (Read 849 times)

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 7482
  • Karma: +186/-120
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
Where have Diagram Tiles Gone?
« on: May 21, 2020, 10:30:23 am »
A while back (several versions ago), we started using Background Tiles on some of our diagrams.  For example, Metamodel diagrams have a specific colour background.

Today, I noticed that they don't.  Investigating, it seems that setting the Background Tile (in v15.1) has no effect! In addition, I can't see where the setting is stored in the DB.  It doesn't seem to be in the usual suspects (t_diagram or t_xref).

Does anybody else have Background Tiles that work?

TIA,
Paolo
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!

Sunshine

  • EA User
  • **
  • Posts: 972
  • Karma: +90/-7
  • Its the results that count
    • View Profile
Re: Where have Diagram Tiles Gone?
« Reply #1 on: May 21, 2020, 02:57:46 pm »
Just tried it on Sparx EA Corp V15.1 Build 1528 and it works fine for me using diagram properties dialog. Working on Windows 10.0.18363.

Happy to help
:)

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 7482
  • Karma: +186/-120
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
Re: Where have Diagram Tiles Gone?
« Reply #2 on: May 21, 2020, 04:19:43 pm »
Just tried it on Sparx EA Corp V15.1 Build 1528 and it works fine for me using diagram properties dialog. Working on Windows 10.0.18363.
Thanks, Sunshine,

That's what I'm on.  I'm playing with our hand-crafted MDG and on one load, the tiles were working (and I found the tile spec in the t_diagram.StyleEx column) but now it's not rendering again!  The tile is held as a path in the BkgPath parameter in StyleEx.  It's there in the DB, but not rendering.

Paolo
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!

Paolo F Cantoni

  • EA Guru
  • *****
  • Posts: 7482
  • Karma: +186/-120
  • Inconsistently correct systems DON'T EXIST!
    • View Profile
Re: Where have Diagram Tiles Gone?
« Reply #3 on: May 21, 2020, 09:16:01 pm »
I've just installed the 15.2 β and the tiles are back!

So far so good!

Paolo
Inconsistently correct systems DON'T EXIST!
... Therefore, aim for consistency; in the expectation of achieving correctness....
-Semantica-
Helsinki Principle Rules!

Sunshine

  • EA User
  • **
  • Posts: 972
  • Karma: +90/-7
  • Its the results that count
    • View Profile
Re: Where have Diagram Tiles Gone?
« Reply #4 on: May 22, 2020, 03:19:48 pm »
Still on V15.1 and I use a custom MDG and the tiles work ok on those diagrams too.
Will have to check out V15.2 too
Happy to help
:)