Author Topic: Archimate Node - same elements - different appearance - SOLVED  (Read 1352 times)

vladap

  • EA User
  • **
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Hi All,

I have small but annoying problem. I have two elements of the same type in one diagram, and both looks different.



It happend after I applied asset to the bigger one and then remove the asset. I checked all the appearance options and I donīt know, where the option with this appearance is  :(

« Last Edit: April 28, 2020, 07:23:03 pm by vladap »

Glassboy

  • EA Practitioner
  • ***
  • Posts: 1366
  • Karma: +110/-75
    • View Profile
Re: Archimate Node - same elements - different appearance
« Reply #1 on: April 28, 2020, 07:38:29 am »
Well, one is displaying compartments so is not an ArchiMate Node.

KP

  • EA Administrator
  • EA Expert
  • *****
  • Posts: 2852
  • Karma: +48/-3
    • View Profile
Re: Archimate Node - same elements - different appearance
« Reply #2 on: April 28, 2020, 07:54:32 am »
It has picked up the decoration part of the ArchiMate shape script, but not the rest, so something odd is happening.

vladap, what version of EA are you using? And when you say "I applied asset" do you mean the element had two stereotypes for a while?
The Sparx Team
support@sparxsystems.com

vladap

  • EA User
  • **
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Archimate Node - same elements - different appearance
« Reply #3 on: April 28, 2020, 05:39:20 pm »
I am using build 1526.
With asset I mean - Appearance - Select an Image Asset.

Here is the DB export of these two objects, I compare it also with newly created Node Object and its the same, so there must be additional table with Object information which is affecting this.

Bigger Node:
654   Class   0   AT FW 10.119.97.254      xxxxx   1.0      133   ArchiMate_Node   0   1   0      -1   0   1   -1   -1   2018-10-29 12:20:24   2020-04-27 15:19:52   Proposed   0   0      Java      0                  Java            1.0   Public         0   {3F51EB1D-C2F4-4a4e-88CB-6A84A0798C19}   0         0   0   0   0   0            ConstructID=0;DefaultImage=0;

Smaller Node:
11770   Class   0   ngiBMD FW 10.238.4.10      xxxxx   1.0   note   133   ArchiMate_Node   0   1   0      -1   0   1   -1   -1   09.03.2020 15:05   09.04.2020 15:04   Proposed   0   0      Java      0                  Java            1.0   Public         0   {89F04D93-EABF-46f3-885D-D4515FBE8640}   0            0   0   0   0                  


« Last Edit: April 28, 2020, 05:59:38 pm by vladap »

vladap

  • EA User
  • **
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Archimate Node - same elements - different appearance
« Reply #4 on: April 28, 2020, 05:52:59 pm »
I tried to remove Stereotype and return it , but same result :

Firstly I removed Stereotype Archiamte , than I set Type Class -> Stereotype Archimate.



vladap

  • EA User
  • **
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Archimate Node - same elements - different appearance
« Reply #5 on: April 28, 2020, 07:22:38 pm »
SOLVED

There was a weird value on t_object - StyleEx clumn (ConstructID=0;DefaultImage=0;), I set it to NULL in DB and object looks and act the same.  :)

KP

  • EA Administrator
  • EA Expert
  • *****
  • Posts: 2852
  • Karma: +48/-3
    • View Profile
Re: Archimate Node - same elements - different appearance
« Reply #6 on: April 29, 2020, 08:18:56 am »
SOLVED

There was a weird value on t_object - StyleEx clumn (ConstructID=0;DefaultImage=0;), I set it to NULL in DB and object looks and act the same.  :)


Those two values would only appear in StyleEx if they used to have a non-zero value and it was changed to zero. If this is affecting the object's appearance it makes me think a setting hasn't been cleared correctly. Could you send in a bug report please, quoting this forum thread.
« Last Edit: April 29, 2020, 08:28:03 am by KP »
The Sparx Team
support@sparxsystems.com