Author Topic: A class has become an enumeration, in sympathy  (Read 337 times)

José Farinha

  • EA User
  • **
  • Posts: 41
  • Karma: +0/-0
    • View Profile
A class has become an enumeration, in sympathy
« on: June 16, 2020, 09:52:53 am »

I've set the stereotype of a class to «enumeration». Strangely, another class connected to the former has also become «enumeration» and turned green.

The real problem is that I can't see a way to remove the stereotype from this class, because the stereotype field is now grayed out and the typical list of stereotypes has shrunk to a single option:
https://photos.google.com/photo/AF1QipO9jeFE6HBaCkCxZuzSNXiyZ4U5bdhS9oJ9S4Ne

Is this problem familiar to anyone?
Any suggestions?

Thanks for your attention
José

Geert Bellekens

  • EA Guru
  • *****
  • Posts: 10438
  • Karma: +343/-30
  • Make EA work for YOU!
    • View Profile
    • Enterprise Architect Consultant and Value Added Reseller
Re: A class has become an enumeration, in sympathy
« Reply #1 on: June 16, 2020, 02:17:46 pm »
Back in the old days enumerations where classes with stereotype «enumeration»
Then (in version 9 I think) they added the object type Enumeration. But EA is still sortof backward compatible with the old way of doing things.

Now to remove the stereotype click on the [...] and uncheck the enumeration stereotype. That will leave you with a regular class.

If you want to change your class into an Enumeration, use the Design | Element | Manage | Change Type menu option.

Geert

José Farinha

  • EA User
  • **
  • Posts: 41
  • Karma: +0/-0
    • View Profile
Re: A class has become an enumeration, in sympathy
« Reply #2 on: June 19, 2020, 08:37:45 am »
Thanks, Geert. You saved me from a lot of work. But it was not straightforward:

I had already tried your first suggestion, but the problem was that the [...] button leads me to a list with a single option: «metaclass». That's the only stereotype available for enumerations.

The Design | ... | Change Type option worked, but only resorting to a trick:
1. I had to change my enumeration-class to an entity,
2. then the «enumeration» stereotype reappears in the [...] list and I could uncheck it,
3. then I changed the type back: entity -> class.