Author Topic: 404 error when trying to connect PCS to Jira - No issues with navigator  (Read 179 times)

Typia

  • EA User
  • **
  • Posts: 47
  • Karma: +0/-0
    • View Profile
Hi guys,
I have an issue trying to connect PCS with Jira in our organization.
When I connect with PCS I have a 404 error in logs :

Code: [Select]
2020-08-28 17:27:29 [WARNING]: HTTP Request Failed.
URL Path: /rest/api/2/projects/
HTTP status code: 404

weird thing is that when I try to connect with navigator using url $serveraddressgiveninpcs$/rest/api/projects/ i just have to authenticate and projects.json downloads correctly.

Could you advice or give a way to debug ?

Many thanks

Typia

  • EA User
  • **
  • Posts: 47
  • Karma: +0/-0
    • View Profile
Re: 404 error when trying to connect PCS to Jira - No issues with navigator
« Reply #1 on: September 01, 2020, 07:04:44 pm »
Hi,
I managed to resolve my issue.
seems like when I restarted PCS Service, SBPI was not restarted and still used old settings.
I had to kill the Jira SBPI task in task manager to make the connection.

My problem now is that I can't get a list of my issues

Here's the log :

Code: [Select]
2020-09-01 11:00:26 [INFO]: HTTP request: /rest/api/2/project/
2020-09-01 11:00:26 [INFO]: Connecting to myserver/jira/
2020-09-01 11:00:26 [WARNING]: Failed to connect to myserver/jira/: The operation completed successfully.
2020-09-01 11:00:26 [SYSTEM]: HTTP response: The operation completed successfully.

Any Sparx PCS admin around ?

Many thanks.

Typia

  • EA User
  • **
  • Posts: 47
  • Karma: +0/-0
    • View Profile
Re: 404 error when trying to connect PCS to Jira - No issues with navigator
« Reply #2 on: September 01, 2020, 10:31:36 pm »
Another update, I managed to make it work.
unlike it was stated in the tutorials I saw, base url had to be filled with "jira"

Now I see my issues