Author Topic: wine and ODBC not working  (Read 1085 times)

Skomorov

  • EA Novice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
wine and ODBC not working
« on: December 24, 2020, 12:26:13 am »
Hello!
fedora 33, wine-6.0-rc3 32-bit, installed jet40, mdac27, mdac28, msxml3-4.
ODBC32 installed and configured.
In EA: Open project->connect to Server->MS ODBC->Use data source name, login, pass->test connection = succseeded and...
"All Enterprise Architect tables in the selected repository are missing, please confirm it is an Enterprise Architect repository and the configured use has the required permissions"
From windows all works,  everyone is connecting to the same DB and it is accessible from other computers.
Could you help?

Geert Bellekens

  • EA Guru
  • *****
  • Posts: 11176
  • Karma: +410/-33
  • Make EA work for YOU!
    • View Profile
    • Enterprise Architect Consultant and Value Added Reseller
Re: wine and ODBC not working
« Reply #1 on: December 24, 2020, 12:41:08 am »
Which driver are you selecting exactly?
"MS ODBC" doesn't seem correct.

Which database are you using?

Geert

Skomorov

  • EA Novice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: wine and ODBC not working
« Reply #2 on: December 24, 2020, 06:59:20 pm »
Hello!
Database mariadb.
Driver mariadb ODBC connector for MS Windows 32-bit latest installed, in wine control ODBC base is selected and connected using the driver. Connection name visible in sparx, i select it, test connection = succseeded. And it doesn't work ..

timoc

  • EA User
  • **
  • Posts: 153
  • Karma: +10/-0
    • View Profile
Re: wine and ODBC not working
« Reply #3 on: December 28, 2020, 12:09:14 am »
Hello!
Database mariadb.
Driver mariadb ODBC connector for MS Windows 32-bit latest installed, in wine control ODBC base is selected and connected using the driver. Connection name visible in sparx, i select it, test connection = succseeded. And it doesn't work ..
Hi,

First, I prefer using code-weavers crossover. If you are going to invest money in a product like EA, you should also consider crossover. It allows you to set up your EA once. It does not need to be re-built/reinstalled when you change distros or perform EA updates, as it does most if not all of the  of the prerequisite installation for you (e.g. fonts, Jet etc.). You can save yourself some hassle there, such as multiple versions of EA, so you can make try the latest update without messing up a working setup. 

My checklist is something like:
in linux:
- setup username password and database access permissions.
- run schema creation and schemea population scripts
- use sql command line client from user running EA, check you can access the EA model.
In Wine 
- (crossover) create bottle backup of working ea setup
- install ODBC drivers (from crossover app menu)
- setup system ODBC DSN according to the Sparx instructions,
- to debug connection.
- Enable 'GLOBAL'  ODBC logging options in System DSN window, and enable 'Tracing' ODBC logging in tracing tab- Move on with successful 'test connection'

With all of that in place, tweak the connection string to setup the provider. E.g. My Postgres connection string looks something like:
Code: [Select]
LocalPG --- DBType=4;Connect=Provider=MSDASQL.1;Persist Security Info=True;Data Source=LocalPG;LazyLoad=1;

With a working setup, i then use crossover to create another EA backup to baseline my working Postgres setup.

Skomorov

  • EA Novice
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: wine and ODBC not working
« Reply #4 on: January 21, 2021, 11:49:40 pm »
Thanks to everyone who responded! Finally solved the problem. Used crossover and old mysql-odbc driver 3.51.25 to connect to mariadb. Wine hangs in a similar situation with the same driver. I even tried to deploy postgresql, under wine the symptoms are the same.