Author Topic: Prolaborate Diagram rendering does not match the EA Diagram  (Read 3517 times)

myeagy85

  • EA Novice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Hi,

We have a custom sort for attributes of an element in EA on a diagram with connectors tied to each attribute (connect to element feature).
When the EA diagram is displayed in Prolaborate the element attributes are alpha sorted (not custom sorted as in the EA diagram).

In some cases this results in crossed lines. How can we get the diagrams to render in Prolaborate like they do in EA?

We are using EA 15.1.1528, PCS 4.2.64, and Prolaborate 3.4.0.

Prolaborate Support

  • Prolab Moderator
  • EA User
  • *
  • Posts: 300
  • Karma: +22/-0
    • View Profile
    • Visit us
Re: Prolaborate Diagram rendering does not match the EA Diagram
« Reply #1 on: May 18, 2021, 10:56:18 pm »
Just to clarify, Prolaborate renders the diagram through data cache generated using Enterprise Architect and with help of APIs provided by Pro Cloud Server (PCS). It does not do any pre or post-processing of diagrams.

Can you please try to create a Data Cache from EA by enabling these two options once again (Learn more here https://prolaborate.sparxsystems.com/resources/documentation/installation-guide?articles=Datacache refer to the section - 5 Create Data Cache) and check whether the issue is resolved.

1. Auto-create Diagram Image and Image Map (each time a Diagram is saved)
2. Auto-create HTML Page (each time a Linked Document is saved)

Note: If it is a humongous model, the data cache will take a long time to complete.