Author Topic: Issue Viewing HTML Output: Screen Just Says "Loading"  (Read 2349 times)

Space_Fan

  • EA Novice
  • *
  • Posts: 14
  • Karma: +0/-0
    • View Profile
Issue Viewing HTML Output: Screen Just Says "Loading"
« on: July 07, 2021, 06:12:58 am »
I'm having an issue viewing an HTML version of an architecture that I've built in Sparx EA v. 14.

The data appears to export successfully, and I can even drill down in the file structure and open up the images of the various architecture views, but when I try to view it by opening the "index.htm" file, it shows a page header with the Sparx logo, and underneath just the word "Loading..."

I've tried leaving it alone to see if it loads eventually, but that didn't work.
I've tried opening the file in Chrome, Firefox, Edge, and IE, and get the same results in all browsers (except IE, which refuses to load anything at all.)

Any suggestions on what I can do to get this to work would be greatly appreciated!


philchudley

  • EA User
  • **
  • Posts: 661
  • Karma: +16/-0
  • UML/EA Principal Consultant / Trainer
    • View Profile
Re: Issue Viewing HTML Output: Screen Just Says "Loading"
« Reply #1 on: July 07, 2021, 06:35:45 am »
HTML viewing requires Javascript to be enabled in the Browser.

For IE, this should already be enabled, but you should see a message indicated that Javscript appears to be disabled and the option to enable it. Once enabled the HTNL should load just fine.

For Chrome and Edge, refer to

https://www.sparxsystems.com/forums/smf/index.php/topic,44676.0.html

Scroll down to the last two replies

Not sure about Firefox since I don't use that Browser, but as far as I am aware should work fine if Javascript is enabled.

Phil
follow me on Twitter

@SparxEAGuru